summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2017-06-24 17:55:02 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2017-06-24 17:56:11 +0200
commitb1bebce1b74f31a806b3e8d0810c4409394b856d (patch)
tree2e5175d1cc1e241832cee61b3cabd92663f4bed5 /x11-themes/kfaenza
parentdev-ada/gnatcoll: 2016 version does not build with gprbuild-2017 (diff)
downloadgentoo-b1bebce1b74f31a806b3e8d0810c4409394b856d.tar.gz
gentoo-b1bebce1b74f31a806b3e8d0810c4409394b856d.tar.bz2
gentoo-b1bebce1b74f31a806b3e8d0810c4409394b856d.zip
x11-themes/kfaenza: Fix invalid file names
...with spaces. Stable revbump. Reported-by: Vit Pelcak <v.pelcak@gmail.com> Gentoo-bug: 620352 Package-Manager: Portage-2.3.6, Repoman-2.3.1
Diffstat (limited to 'x11-themes/kfaenza')
-rw-r--r--x11-themes/kfaenza/kfaenza-0.8.9-r2.ebuild55
1 files changed, 55 insertions, 0 deletions
diff --git a/x11-themes/kfaenza/kfaenza-0.8.9-r2.ebuild b/x11-themes/kfaenza/kfaenza-0.8.9-r2.ebuild
new file mode 100644
index 000000000000..b8a13c66e909
--- /dev/null
+++ b/x11-themes/kfaenza/kfaenza-0.8.9-r2.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+MY_PN="KFaenza"
+DESCRIPTION="Faenza-Cupertino icon theme for KDE Plasma"
+HOMEPAGE="http://kde-look.org/content/show.php/KFaenza?content=143890 http://kde-look.org/content/show.php/KFaenza+icon+patch?content=153813 http://kde-look.org/content/show.php/Additional+KFaenza+Icons?content=147483"
+#That is upstream location, not reupload. Don't fix
+SRC_URI="http://ompldr.org/vYjR0NQ/${P}.tar.gz
+ http://kde-look.org/CONTENT/content-files/153813-${PN}-icon-patch-0.3.tar.gz
+ additional? ( http://kde-look.org/CONTENT/content-files/147483-additional-KFaenza.tar.gz )"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="+additional branding"
+
+S="${WORKDIR}/${MY_PN}"
+RESTRICT="binchecks strip"
+
+src_unpack() {
+ unpack ${P}.tar.gz
+ pushd "${S}" > /dev/null
+ for tarball in ${A}; do
+ [[ "${tarball}" == ${P}.tar.gz ]] && continue
+ unpack "${tarball}"
+ done
+ popd > /dev/null
+}
+
+src_prepare() {
+ default
+
+ # Gentoo bug 620352
+ local f
+ for f in 16 22 32 48; do
+ mv apps/${f}/"numpty physics.png" apps/${f}/"numptyphysics.png" || die
+ done
+
+ use branding || return
+
+ local res
+ for res in 22 32 48 64 128 256; do
+ cp "${S}"/places/${res}/start-here-gentoo.png \
+ "${S}"/places/${res}/start-here.png || die
+ done
+ cp "${S}"/places/scalable/start-here-gentoo.svg \
+ "${S}"/places/scalable/start-here.svg || die
+}
+
+src_install() {
+ dodir /usr/share/icons
+ cp -R "${S}/" "${D}"/usr/share/icons || die "Install failed!"
+}