summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-09-06 14:00:22 +0200
committerMichał Górny <mgorny@gentoo.org>2023-09-06 14:26:39 +0200
commitdf0bdb2356cd5854720db51648dabb0a56bb9184 (patch)
tree256e58db8a00f08ccbc408db6d42732b7e25e05a /x11-themes/elementary-xfce-icon-theme
parentdev-lang/python: Bump to 3.12.0_rc2 (diff)
downloadgentoo-df0bdb2356cd5854720db51648dabb0a56bb9184.tar.gz
gentoo-df0bdb2356cd5854720db51648dabb0a56bb9184.tar.bz2
gentoo-df0bdb2356cd5854720db51648dabb0a56bb9184.zip
x11-themes/elementary-xfce-icon-theme: Bump to 0.18
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'x11-themes/elementary-xfce-icon-theme')
-rw-r--r--x11-themes/elementary-xfce-icon-theme/Manifest1
-rw-r--r--x11-themes/elementary-xfce-icon-theme/elementary-xfce-icon-theme-0.18.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/x11-themes/elementary-xfce-icon-theme/Manifest b/x11-themes/elementary-xfce-icon-theme/Manifest
index 0c18186cd09d..4a774694edaf 100644
--- a/x11-themes/elementary-xfce-icon-theme/Manifest
+++ b/x11-themes/elementary-xfce-icon-theme/Manifest
@@ -2,3 +2,4 @@ DIST elementary-xfce-0.15.1.tar.gz 6198394 BLAKE2B 18638aa2c55a01a48fc342a836c92
DIST elementary-xfce-0.15.2.tar.gz 6215682 BLAKE2B 917f9b8f555a02d01807695b67857e4f31b3a1d6229727f992c299f119641c1ec2c62098473f7617a77cd25ba8e385cbb2209d2bf73554cb6934faf610a18b00 SHA512 c7d62dc38295ed9fa66e9e21f06d18bdd095aaa6f5f012065e70517117d8daa05c3a25942185fdfcd5a2b79e510c55983a09dee79568e95e8f22e6199ec28ef0
DIST elementary-xfce-0.16.tar.gz 6983116 BLAKE2B e33f244d6a19ba447149981e57cc5a41a98f17039ba0ae546945b75dabefde3bc15288fb8d09b00c500de8cf11ed37160b0b35d7d653d9a8eb29ed6117edb723 SHA512 d1f1338e3b6d2835741835be04db03154bef8fc53dd365855f646c3668f108f1a6d2ea7c7e8b07152f79cfcf29dc9959b2363417ca19b425da908c913fdab960
DIST elementary-xfce-0.17.tar.gz 6964314 BLAKE2B 3dbeb664a0ad6fbcca916df7103057e63ff988456471070f62e020188d3f7dd900ded634c5e13b9b80780c2c5514a7155c533df3537c791da54f367a13834cc3 SHA512 3e577f8f800b77f2efaa17877d0031790a700b4d0433e6ab5d6ce2f859941160291a32a0a042e5ad99e81e631042db1abedc31c2f657ee025df1807fbb456720
+DIST elementary-xfce-0.18.tar.gz 6915651 BLAKE2B b9d1674296c2648f6ad3f31cd5162c44b2c472761dd57811138d97cf42a1e52576fca9541bf63337fcf9208736845f982b9b71deb76f43d6114ac99ab095492d SHA512 50157429c1c702e3b167168d7f28de8b61439fb00b926326cea9ff1f60753134be79ce3685987f3875a6609b45697bac55b0d31920e47deb3ba8c39185d9ea39
diff --git a/x11-themes/elementary-xfce-icon-theme/elementary-xfce-icon-theme-0.18.ebuild b/x11-themes/elementary-xfce-icon-theme/elementary-xfce-icon-theme-0.18.ebuild
new file mode 100644
index 000000000000..521c097975a9
--- /dev/null
+++ b/x11-themes/elementary-xfce-icon-theme/elementary-xfce-icon-theme-0.18.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit xdg toolchain-funcs
+
+MY_P="${PN%-icon-theme}-${PV}"
+DESCRIPTION="Elementary icons forked from upstream, extended and maintained for Xfce"
+HOMEPAGE="https://github.com/shimmerproject/elementary-xfce"
+SRC_URI="https://github.com/shimmerproject/elementary-xfce/archive/v${PV}.tar.gz -> ${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="public-domain GPL-1 GPL-2 GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv ~x86"
+
+BDEPEND="
+ media-gfx/optipng
+ x11-libs/gdk-pixbuf:2
+ x11-libs/gtk+:3"
+
+src_prepare() {
+ sed -i -e 's:-Werror -O0 -pipe:${CFLAGS} ${CPPFLAGS} ${LDFLAGS}:' \
+ svgtopng/Makefile || die
+ default
+}
+
+src_configure() {
+ # custom script
+ ./configure --prefix="${EPREFIX}/usr" || die
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)"
+}
+
+src_install() {
+ default
+ # delete dangling doc links
+ find -L "${D}" -type l -delete || die
+}