summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2022-04-07 21:38:34 +0100
committerJames Le Cuirot <chewi@gentoo.org>2022-04-07 21:38:34 +0100
commitac54ac8ce2fd6028dae95f4e4509d16e4bb3fb66 (patch)
tree6001166552f520cc01734324d771dec0e23af14c /x11-themes/arc-theme
parentdev-cpp/gulrak-filesystem: Bump to 1.5.12, drop old 1.5.10 (diff)
downloadgentoo-ac54ac8ce2fd6028dae95f4e4509d16e4bb3fb66.tar.gz
gentoo-ac54ac8ce2fd6028dae95f4e4509d16e4bb3fb66.tar.bz2
gentoo-ac54ac8ce2fd6028dae95f4e4509d16e4bb3fb66.zip
x11-themes/arc-theme: Version bump to 20220405
Signed-off-by: James Le Cuirot <chewi@gentoo.org>
Diffstat (limited to 'x11-themes/arc-theme')
-rw-r--r--x11-themes/arc-theme/Manifest1
-rw-r--r--x11-themes/arc-theme/arc-theme-20220405.ebuild78
2 files changed, 79 insertions, 0 deletions
diff --git a/x11-themes/arc-theme/Manifest b/x11-themes/arc-theme/Manifest
index 060d58fb23dc..ba44eddff3d4 100644
--- a/x11-themes/arc-theme/Manifest
+++ b/x11-themes/arc-theme/Manifest
@@ -2,3 +2,4 @@ DIST arc-theme-20210412-pngs.tar.xz 159340 BLAKE2B 40027335b8b44ae38bfadfa52e088
DIST arc-theme-20210412.tar.xz 257248 BLAKE2B c525c3632670d8aa6b640baa8b3dddca6c5dd5f087734604c68d9140f810fc595f73db06f93b6193ba1c59a8cd85b87f5f6fda9777940adf36f3c436a8426810 SHA512 d3064546301e013a1e5a8db735346d74c73f37cbf808b7afeee6f88c820cea58ba6458fa63e1213377cdd33c8347167242e6f8f1eacf85ce212f3b2508c0bb80
DIST arc-theme-20220105.tar.xz 342432 BLAKE2B 37a4e196fbbe532e4f9036681770fb90843c8a4645b8218c471f2f5f68e7c0c07107a71698634a61553ba4f22f483a336b113ff6906fed48c0285a67321d0896 SHA512 dc2a1e1dad03fd187e8e571b752e52d73c7cbed24f3228f1782c4a4897b1085e2466f6f8373af32d650ad9835df3ad19a1206f3fa55d543115092aa46118e31f
DIST arc-theme-20220223.tar.xz 343044 BLAKE2B 7bdd3689eae270a97d5405c2eaf523b9d81284c1860d39de5f46a7c32d75dd24f745a5264d76625c08c2185ad87e65a99e93d39be753dc0304a86daa863df3cd SHA512 33a0e73e9951fcfe74f80af5e1449df23a5564d11a26b930cbc17b0f74887aedf2634579da1e0484e22465422f62559c801dbcd35221fbb7b7fc783671103aa4
+DIST arc-theme-20220405.tar.xz 346512 BLAKE2B 49a25b302e6641b5234f0d3e4bddda84eb0136333b3c513dc9ca08be9b966c75c299289390cdd64c62bdeeed9f457ff01524b2da95029c78b32c3603aaff23c8 SHA512 16655b822548820945c5fd3c0bb809d1e55db887c3b5c5309f4acd82c4dd7dd8255d246d86025231c73a303e647bb61c7f9cdc63a04f813cfb79fadf27dec204
diff --git a/x11-themes/arc-theme/arc-theme-20220405.ebuild b/x11-themes/arc-theme/arc-theme-20220405.ebuild
new file mode 100644
index 000000000000..dddb29af6aa3
--- /dev/null
+++ b/x11-themes/arc-theme/arc-theme-20220405.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit meson python-any-r1
+
+DESCRIPTION="A flat theme with transparent elements for GTK 2/3/4 and GNOME Shell"
+HOMEPAGE="https://github.com/jnsh/arc-theme"
+SRC_URI="https://github.com/jnsh/${PN}/releases/download/${PV}/arc-theme-${PV}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+IUSE="cinnamon gnome-shell +gtk2 +gtk3 +gtk4 mate +transparency xfce"
+
+GLIB_DEPEND="dev-libs/glib"
+SASSC_DEPEND="dev-lang/sassc"
+
+# Supports various GTK, GNOME Shell, and Cinnamon versions and uses
+# --version option for gnome-shell and cinnamon to determine which set of files to build.
+# Updates will therefore break existing installs but there's no way around this.
+BDEPEND="
+ ${PYTHON_DEPS}
+ >=dev-util/meson-0.56.0
+ cinnamon? (
+ ${SASSC_DEPEND}
+ gnome-extra/cinnamon
+ )
+ gnome-shell? (
+ ${GLIB_DEPEND}
+ ${SASSC_DEPEND}
+ >=gnome-base/gnome-shell-3.28
+ )
+ gtk3? (
+ ${GLIB_DEPEND}
+ ${SASSC_DEPEND}
+ )
+ gtk4? (
+ ${GLIB_DEPEND}
+ ${SASSC_DEPEND}
+ )
+"
+
+# gnome-themes-standard is only needed by GTK+2 for the Adwaita
+# engine. This engine is built into GTK+3.
+RDEPEND="
+ gtk2? (
+ x11-themes/gnome-themes-standard
+ x11-themes/gtk-engines-murrine
+ )
+"
+
+src_configure() {
+ # Cinnamon still uses metacity themes for its window manager.
+ # so we enable metacity theme too if USE=cinnamon
+ # but only enable metacity if USE=mate
+ local themes=$(
+ printf "%s," \
+ $(usev cinnamon "cinnamon metacity") \
+ $(usev gnome-shell) \
+ $(usev gtk2) \
+ $(usev gtk3) \
+ $(usev gtk4) \
+ $(! use cinnamon && usev mate metacity) \
+ $(usev xfce xfwm)
+ )
+
+ local emesonargs=(
+ -Dthemes="${themes%,}"
+ $(meson_use gnome-shell gnome_shell_gresource)
+ $(meson_use transparency)
+ )
+
+ meson_src_configure
+}