summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-02-29 15:42:36 +0100
committerMichał Górny <mgorny@gentoo.org>2024-02-29 15:42:36 +0100
commit90975e7f5eddbd7af02535669e2206f4a9e9d125 (patch)
tree10ff770a36dbf7024eb04af490a055e1275adeb0 /x11-terms
parentxfce-base/xfce4-panel: Bump to 4.19.3 (diff)
downloadgentoo-90975e7f5eddbd7af02535669e2206f4a9e9d125.tar.gz
gentoo-90975e7f5eddbd7af02535669e2206f4a9e9d125.tar.bz2
gentoo-90975e7f5eddbd7af02535669e2206f4a9e9d125.zip
x11-terms/xfce4-terminal: Bump to 1.1.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'x11-terms')
-rw-r--r--x11-terms/xfce4-terminal/Manifest1
-rw-r--r--x11-terms/xfce4-terminal/xfce4-terminal-1.1.3.ebuild59
2 files changed, 60 insertions, 0 deletions
diff --git a/x11-terms/xfce4-terminal/Manifest b/x11-terms/xfce4-terminal/Manifest
index 48198428008a..337bcdc07caf 100644
--- a/x11-terms/xfce4-terminal/Manifest
+++ b/x11-terms/xfce4-terminal/Manifest
@@ -1,2 +1,3 @@
DIST xfce4-terminal-1.1.1.tar.bz2 1033180 BLAKE2B e33bf7f0ff56200154a7195b6aaf09a7b67c7577c78190fd110b1dc035914295735925bf82f0cd3b6809646315236a32fc835acbb8d97b73b57025205faef9e8 SHA512 0f2631cc9790b467495cf17a506c33b9c6a037b94a353cb870554b1dd9da0b4795ed965ca2e9beb5dec1b344304e4dc9f71130862f6b45d63f66c603757991cd
DIST xfce4-terminal-1.1.2.tar.bz2 1042199 BLAKE2B 5919899a7e76e31a05f13485a38564a38dba37335b412a7d548d107ea8ed5eea9edb087ac75e9a90364b5e9a0aaa4b8b32342ac3a8e026da0c3cf73bd8903c81 SHA512 ffd0975dc839e256ee18c8a5cb01025bfc2703af7d379d565ea861482269698c718c4cca408440cdc76ef7c6ccacaa6816da7f6734b1aef004cfb223f657243a
+DIST xfce4-terminal-1.1.3.tar.bz2 1042732 BLAKE2B e4cdd24a19525f6da16483e1db7d80995396600d80b857e56c9859c25c3a54ba324205ab4938e3cea66da18495c8c32b8cc85ad4583593e289246ea3dbd34b74 SHA512 12d489099851b281d3ac83a4d9b2f459ed8442899823edba36055a0aa731d1821686f400d5d370833077b0ccf930cb3dfdf5800af58dd2339377dd7e902210b9
diff --git a/x11-terms/xfce4-terminal/xfce4-terminal-1.1.3.ebuild b/x11-terms/xfce4-terminal/xfce4-terminal-1.1.3.ebuild
new file mode 100644
index 000000000000..1937b280276f
--- /dev/null
+++ b/x11-terms/xfce4-terminal/xfce4-terminal-1.1.3.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit xdg-utils
+
+DESCRIPTION="A terminal emulator for the Xfce desktop environment"
+HOMEPAGE="
+ https://docs.xfce.org/apps/terminal/start
+ https://gitlab.xfce.org/apps/xfce4-terminal/
+"
+SRC_URI="https://archive.xfce.org/src/apps/${PN}/$(ver_cut 1-2)/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-solaris"
+IUSE="utempter wayland X"
+REQUIRED_USE="|| ( wayland X )"
+
+RDEPEND="
+ >=dev-libs/glib-2.44.0:2
+ >=dev-libs/libpcre2-10.00:=
+ >=x11-libs/gtk+-3.22.0:3[wayland?,X?]
+ >=x11-libs/vte-0.51.3:2.91
+ >=xfce-base/libxfce4ui-4.17.5:=[gtk3(+)]
+ >=xfce-base/xfconf-4.16.0:=
+ utempter? ( sys-libs/libutempter:= )
+ wayland? ( >=gui-libs/gtk-layer-shell-0.7.0 )
+ X? ( >=x11-libs/libX11-1.6.7 )
+"
+DEPEND="
+ ${RDEPEND}
+"
+BDEPEND="
+ dev-libs/libxml2
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+src_configure() {
+ local myconf=(
+ $(use_with utempter)
+ $(use_enable wayland)
+ $(use_enable wayland gtk-layer-shell)
+ $(use_enable X x11)
+ )
+
+ econf "${myconf[@]}"
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}