summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2022-11-20 19:35:14 -0500
committerIonen Wolkens <ionen@gentoo.org>2022-11-20 19:37:24 -0500
commitc33f16b0f0cb13ea27db76be99d779af4431a89d (patch)
tree7f59efef7ba9565993cdfe9f0340fafbd05a01ab /x11-plugins
parentmedia-video/setpwc: fix build w/ upcoming clang16 (diff)
downloadgentoo-c33f16b0f0cb13ea27db76be99d779af4431a89d.tar.gz
gentoo-c33f16b0f0cb13ea27db76be99d779af4431a89d.tar.bz2
gentoo-c33f16b0f0cb13ea27db76be99d779af4431a89d.zip
x11-plugins/wmstickynotes: fix build w/ upcoming clang16
Also set bit more explicit deps while revbumping. Closes: https://bugs.gentoo.org/874927 Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'x11-plugins')
-rw-r--r--x11-plugins/wmstickynotes/files/wmstickynotes-0.7-clang16.patch8
-rw-r--r--x11-plugins/wmstickynotes/wmstickynotes-0.7-r1.ebuild (renamed from x11-plugins/wmstickynotes/wmstickynotes-0.7.ebuild)21
2 files changed, 27 insertions, 2 deletions
diff --git a/x11-plugins/wmstickynotes/files/wmstickynotes-0.7-clang16.patch b/x11-plugins/wmstickynotes/files/wmstickynotes-0.7-clang16.patch
new file mode 100644
index 000000000000..7674dcfd4984
--- /dev/null
+++ b/x11-plugins/wmstickynotes/files/wmstickynotes-0.7-clang16.patch
@@ -0,0 +1,8 @@
+https://bugs.gentoo.org/874927
+--- a/wmstickynotes.h
++++ b/wmstickynotes.h
+@@ -34,3 +34,3 @@
+
+-const num_color_schemes = 8;
++const int num_color_schemes = 8;
+ ColorScheme color_schemes[] = {
diff --git a/x11-plugins/wmstickynotes/wmstickynotes-0.7.ebuild b/x11-plugins/wmstickynotes/wmstickynotes-0.7-r1.ebuild
index 8b8830387ff3..3058805ac1e9 100644
--- a/x11-plugins/wmstickynotes/wmstickynotes-0.7.ebuild
+++ b/x11-plugins/wmstickynotes/wmstickynotes-0.7-r1.ebuild
@@ -3,6 +3,8 @@
EAPI=8
+inherit flag-o-matic
+
DESCRIPTION="A dockapp for keeping small notes around on the desktop"
HOMEPAGE="https://sourceforge.net/projects/wmstickynotes/"
SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
@@ -11,5 +13,20 @@ LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"
-DEPEND="x11-libs/gtk+:2"
-RDEPEND="${DEPEND}"
+RDEPEND="
+ dev-libs/glib:2
+ x11-libs/gtk+:2
+ x11-libs/libX11"
+DEPEND="
+ ${RDEPEND}
+ x11-base/xorg-proto"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-clang16.patch
+)
+
+src_configure() {
+ append-cppflags -D_GNU_SOURCE #874927
+
+ default
+}