summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-plugins/wmcpu
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-plugins/wmcpu')
-rw-r--r--x11-plugins/wmcpu/Manifest1
-rw-r--r--x11-plugins/wmcpu/metadata.xml5
-rw-r--r--x11-plugins/wmcpu/wmcpu-1.4.ebuild40
3 files changed, 46 insertions, 0 deletions
diff --git a/x11-plugins/wmcpu/Manifest b/x11-plugins/wmcpu/Manifest
new file mode 100644
index 000000000000..ef15dcb0dcdd
--- /dev/null
+++ b/x11-plugins/wmcpu/Manifest
@@ -0,0 +1 @@
+DIST wmcpu-1.4.tar.gz 6712 RMD160 eab6a93544a8396264bbdcc885783c68f33123d6 SHA1 1f6e4380630a9618b3edf3f70d1dcb774066bd75 SHA256 efd07c417acd1e1b28dd5c3a76e98e207261f68aa17784ccef252e8e80145e0f
diff --git a/x11-plugins/wmcpu/metadata.xml b/x11-plugins/wmcpu/metadata.xml
new file mode 100644
index 000000000000..b1a9efc4f2f0
--- /dev/null
+++ b/x11-plugins/wmcpu/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>desktop-dock</herd>
+</pkgmetadata>
diff --git a/x11-plugins/wmcpu/wmcpu-1.4.ebuild b/x11-plugins/wmcpu/wmcpu-1.4.ebuild
new file mode 100644
index 000000000000..09821ea988f4
--- /dev/null
+++ b/x11-plugins/wmcpu/wmcpu-1.4.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="3"
+
+inherit flag-o-matic
+
+DESCRIPTION="wmcpu is a dockapp to monitor memory and CPU usage, similar to xosview"
+HOMEPAGE="http://dockapps.windowmaker.org/file.php/id/306"
+SRC_URI="http://denilsonsa.sh.nu/~denilson/${P}.tar.gz
+ http://denilsonsa.selfip.org/~denilson/${P}.tar.gz
+ http://dockapps.windowmaker.org/download.php/id/673/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86"
+IUSE=""
+
+DEPEND="x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXpm"
+RDEPEND="${RDEPEND}
+ x11-proto/xextproto"
+
+src_prepare() {
+ #Honour Gentoo LDFLAGS, see bug #337523
+ sed -e 's/LDFLAGS/LIBS/g' -i Makefile
+ sed -e 's/\$(CFLAGS)/\$(LDFLAGS)/' -i Makefile
+}
+
+src_compile() {
+ # We then add the default -Wall from Makefile to CFLAGS
+ emake CFLAGS="${CFLAGS} -Wall" || die "emake failed"
+}
+
+src_install () {
+ dobin wmcpu
+ dodoc ChangeLog README
+}