summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2024-06-09 11:32:17 -0400
committerMatt Turner <mattst88@gentoo.org>2024-06-09 11:37:36 -0400
commit7e99d53307fb95fb254c9f8ef8d9e0711e707ecc (patch)
tree6800b6ce951440abc01a4dfe83ddf45d39ade9d8 /x11-misc
parentdev-util/spirv-llvm-translator: Version bump to 18.1.1 (diff)
downloadgentoo-7e99d53307fb95fb254c9f8ef8d9e0711e707ecc.tar.gz
gentoo-7e99d53307fb95fb254c9f8ef8d9e0711e707ecc.tar.bz2
gentoo-7e99d53307fb95fb254c9f8ef8d9e0711e707ecc.zip
x11-misc/xkeyboard-config: Version bump to 2.42
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/xkeyboard-config/Manifest1
-rw-r--r--x11-misc/xkeyboard-config/xkeyboard-config-2.42.ebuild66
-rw-r--r--x11-misc/xkeyboard-config/xkeyboard-config-9999.ebuild1
3 files changed, 67 insertions, 1 deletions
diff --git a/x11-misc/xkeyboard-config/Manifest b/x11-misc/xkeyboard-config/Manifest
index bfc8f0232e33..7d07d1ab956d 100644
--- a/x11-misc/xkeyboard-config/Manifest
+++ b/x11-misc/xkeyboard-config/Manifest
@@ -1 +1,2 @@
DIST xkeyboard-config-2.41.tar.xz 898404 BLAKE2B f608c30b31c26f2273907f45929a0fe9e44bb9513d45a791be1ff3fb8da5cd56d4fbb182540c47960f16841a30f89fdab0ad87cc41597c02bfd76643fff6857d SHA512 108c1d0a8344e15f5d92f876a1b008571f6dbe57aecf2797757accc1f3f031a07dfb4ba5028e06784620810dd835ddd5afadf68e2d73594ae96b7520b0bbde7a
+DIST xkeyboard-config-2.42.tar.xz 910192 BLAKE2B 1b49a9bdf9e6ad2c196b8c4cc93803a2b4ce804148a7eb55616672db5c4d3eb289e2de931ee8b08a2152dd542a9f2d1e00ba8cca7651d7f33b570ed4a5f4c57b SHA512 654436ae21b9deb3b193847403b652cc5c19aa665a9c9168598fc6ac7af83ac04d40684d9eb99dd4db97c21e5100cfeed06b25e2b041eb9fdf3c05ef95a891a9
diff --git a/x11-misc/xkeyboard-config/xkeyboard-config-2.42.ebuild b/x11-misc/xkeyboard-config/xkeyboard-config-2.42.ebuild
new file mode 100644
index 000000000000..33edbae597e4
--- /dev/null
+++ b/x11-misc/xkeyboard-config/xkeyboard-config-2.42.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+inherit meson python-any-r1
+
+DESCRIPTION="X keyboard configuration database"
+HOMEPAGE="https://www.freedesktop.org/wiki/Software/XKeyboardConfig https://gitlab.freedesktop.org/xkeyboard-config/xkeyboard-config"
+
+if [[ ${PV} == 9999 ]]; then
+ EGIT_REPO_URI="https://gitlab.freedesktop.org/xkeyboard-config/xkeyboard-config.git"
+ inherit git-r3
+else
+ SRC_URI="https://www.x.org/releases/individual/data/${PN}/${P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+ dev-lang/perl
+ dev-libs/libxslt
+ sys-devel/gettext
+ test? (
+ ${PYTHON_DEPS}
+ x11-apps/xkbcomp
+ x11-libs/libxkbcommon
+ $(python_gen_any_dep '
+ dev-python/pycountry[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ ')
+ )
+"
+
+python_check_deps() {
+ use test || return 0
+ python_has_version \
+ "dev-python/pycountry[${PYTHON_USEDEP}]" \
+ "dev-python/pytest-xdist[${PYTHON_USEDEP}]" \
+ "dev-python/pytest[${PYTHON_USEDEP}]"
+}
+
+pkg_setup() {
+ use test && python-any-r1_pkg_setup
+}
+
+src_prepare() {
+ eapply_user
+
+ # Remove pytest timeout
+ sed -i -e "/test('pytest'/,/)$/ { s/timeout: [0-9]*/timeout: 0/ }" meson.build || die
+}
+
+src_configure() {
+ local emesonargs=(
+ -Dxkb-base="${EPREFIX}/usr/share/X11/xkb"
+ -Dcompat-rules=true
+ )
+ meson_src_configure
+}
diff --git a/x11-misc/xkeyboard-config/xkeyboard-config-9999.ebuild b/x11-misc/xkeyboard-config/xkeyboard-config-9999.ebuild
index 8dccf01c3ce0..33edbae597e4 100644
--- a/x11-misc/xkeyboard-config/xkeyboard-config-9999.ebuild
+++ b/x11-misc/xkeyboard-config/xkeyboard-config-9999.ebuild
@@ -22,7 +22,6 @@ SLOT="0"
IUSE="test"
RESTRICT="!test? ( test )"
-# <dev-python/pycountry-23.12.7 bug #920278
BDEPEND="
dev-lang/perl
dev-libs/libxslt