summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-misc/xteddy
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-misc/xteddy')
-rw-r--r--x11-misc/xteddy/Manifest1
-rw-r--r--x11-misc/xteddy/files/xteddy-2.2-linking.patch22
-rw-r--r--x11-misc/xteddy/metadata.xml12
-rw-r--r--x11-misc/xteddy/xteddy-2.2.ebuild31
4 files changed, 66 insertions, 0 deletions
diff --git a/x11-misc/xteddy/Manifest b/x11-misc/xteddy/Manifest
new file mode 100644
index 000000000000..e0d2095b8159
--- /dev/null
+++ b/x11-misc/xteddy/Manifest
@@ -0,0 +1 @@
+DIST xteddy-2.2.tar.gz 867005 SHA256 d8885a1e2e08787cb469857a9404619cadab9bddcae7fa398a565d53633291e2 SHA512 e48f1f616980b747b3e528a7bb3a46605986e87e05cbad1385992931098acd8857cdd9fa7c38bca94007e74d1ab13cfd567fe6e502eecf8691e24272bd98159b WHIRLPOOL 3c479fa2ea3bc1f097a32c33bc15ea57c1cdb11fb830488865020a79c277a9d668c8e38ce6bc77da5398e7fcd92f91ce936bb88decce7fe0e94e8aa7755352fc
diff --git a/x11-misc/xteddy/files/xteddy-2.2-linking.patch b/x11-misc/xteddy/files/xteddy-2.2-linking.patch
new file mode 100644
index 000000000000..6dd01e48f5e9
--- /dev/null
+++ b/x11-misc/xteddy/files/xteddy-2.2-linking.patch
@@ -0,0 +1,22 @@
+--- a/configure.in
++++ b/configure.in
+@@ -5,6 +5,8 @@
+
+ AC_PATH_XTRA
+ PKG_CHECK_MODULES(IMLIB2, imlib2)
++PKG_CHECK_MODULES(X11, x11)
++PKG_CHECK_MODULES(XEXT, xext)
+
+ PIXMAP_PATH="/usr/share/xteddy"
+ AC_SUBST(PIXMAP_PATH)
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -7,7 +7,7 @@
+ bin_SCRIPTS = xtoys xteddy_test
+
+ AM_CFLAGS = @IMLIB2_CFLAGS@
+-AM_LDFLAGS = @IMLIB2_LIBS@ -lX11
++xteddy_LDADD = @IMLIB2_LIBS@ @X11_LIBS@ @XEXT_LIBS@
+
+ DEFS = -DPIXMAP_PATH=\"@PIXMAP_PATH@\" -Wall
+
diff --git a/x11-misc/xteddy/metadata.xml b/x11-misc/xteddy/metadata.xml
new file mode 100644
index 000000000000..61b5fb040877
--- /dev/null
+++ b/x11-misc/xteddy/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>desktop-misc</herd>
+ <longdescription lang="en">
+ Normally, xteddy just sits around doing nothing. After all, that's what
+ teddy bears are for. Look at him, talk to him, place heavy windows on
+ top of him, zap him around until he becomes dizzy, do what you like; he
+ will always be your true (albeit virtual) friend. Now you can load other
+ pixmaps than the nice teddy, too.
+ </longdescription>
+</pkgmetadata>
diff --git a/x11-misc/xteddy/xteddy-2.2.ebuild b/x11-misc/xteddy/xteddy-2.2.ebuild
new file mode 100644
index 000000000000..fcc6fd287e28
--- /dev/null
+++ b/x11-misc/xteddy/xteddy-2.2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit autotools eutils
+
+DESCRIPTION="A cuddly teddy bear (or other image) for your X desktop"
+HOMEPAGE="http://webstaff.itn.liu.se/~stegu/xteddy/"
+SRC_URI="http://webstaff.itn.liu.se/~stegu/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND="media-libs/imlib2[X,png]
+ x11-libs/libX11
+ x11-libs/libXext"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+DOCS=( AUTHORS README ChangeLog NEWS xteddy.README )
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-linking.patch
+
+ # Fix paths in xtoys script wrt bug #404899
+ sed -i -e "s:/usr/games:/usr/bin:" xtoys || die
+ eautoreconf
+}