summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKarl Linden <karl.j.linden@gmail.com>2018-03-17 08:57:47 +0100
committerMichał Górny <mgorny@gentoo.org>2018-03-17 09:34:20 +0100
commit27c925f82d0bd84aecb3f1173e36bc02e20fc4e7 (patch)
treeb35ee106a23ff86ed04f672bdc7ae201c3453751 /x11-misc/xkblayout-state/xkblayout-state-0_p20180118.ebuild
parentdev-perl/Tk-TableMatrix: EAPI6 + tests (diff)
downloadgentoo-27c925f82d0bd84aecb3f1173e36bc02e20fc4e7.tar.gz
gentoo-27c925f82d0bd84aecb3f1173e36bc02e20fc4e7.tar.bz2
gentoo-27c925f82d0bd84aecb3f1173e36bc02e20fc4e7.zip
x11-misc/xkblayout-state: Initial commit
Closes: https://github.com/gentoo/gentoo/pull/6389 Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'x11-misc/xkblayout-state/xkblayout-state-0_p20180118.ebuild')
-rw-r--r--x11-misc/xkblayout-state/xkblayout-state-0_p20180118.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/x11-misc/xkblayout-state/xkblayout-state-0_p20180118.ebuild b/x11-misc/xkblayout-state/xkblayout-state-0_p20180118.ebuild
new file mode 100644
index 000000000000..afbeba66bacf
--- /dev/null
+++ b/x11-misc/xkblayout-state/xkblayout-state-0_p20180118.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit toolchain-funcs
+
+# Commit Date: 18 Jan 2018
+EGIT_COMMIT="45b752b130e077d5b1437d40b0a459e062aafa13"
+
+DESCRIPTION="A small program to get/set the current XKB layout"
+HOMEPAGE="https://github.com/nonpop/xkblayout-state"
+SRC_URI="https://github.com/nonpop/xkblayout-state/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+S="${WORKDIR}/${PN}-${EGIT_COMMIT}"
+
+RDEPEND="x11-libs/libX11"
+DEPEND="${RDEPEND}"
+
+src_compile() {
+ emake CXX="$(tc-getCXX)"
+}
+
+src_install() {
+ emake PREFIX="${EPREFIX}"/usr DESTDIR="${D}" install
+}