summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <sudinave@gmail.com>2021-02-25 10:15:01 +0100
committerDavid Seifert <soap@gentoo.org>2021-02-25 10:15:01 +0100
commitdb88575e4c9d910338b2089827a478e57b97df04 (patch)
tree95c4823d2dfb7492e9781264c17b1a11af544580 /x11-misc/unclutter-xfixes
parentx11-misc/unclutter-xfixes: adopt through proxy-maint (diff)
downloadgentoo-db88575e4c9d910338b2089827a478e57b97df04.tar.gz
gentoo-db88575e4c9d910338b2089827a478e57b97df04.tar.bz2
gentoo-db88575e4c9d910338b2089827a478e57b97df04.zip
x11-misc/unclutter-xfixes: fix CC usage + cleanups
`make install` caused both bugs and installed in /usr/share/licenses. Given only an executable + man page simpler to do it manually than fix. Also updated DESCRIPTION based on original unclutter, previous was taken from upstream but doesn't explain what this does. Closes: https://bugs.gentoo.org/726234 Closes: https://bugs.gentoo.org/742749 Package-Manager: Portage-3.0.15, Repoman-3.0.2 Signed-off-by: Ionen Wolkens <sudinave@gmail.com> Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'x11-misc/unclutter-xfixes')
-rw-r--r--x11-misc/unclutter-xfixes/unclutter-xfixes-1.5-r1.ebuild31
-rw-r--r--x11-misc/unclutter-xfixes/unclutter-xfixes-1.5-r2.ebuild37
2 files changed, 37 insertions, 31 deletions
diff --git a/x11-misc/unclutter-xfixes/unclutter-xfixes-1.5-r1.ebuild b/x11-misc/unclutter-xfixes/unclutter-xfixes-1.5-r1.ebuild
deleted file mode 100644
index 3e79355700b4..000000000000
--- a/x11-misc/unclutter-xfixes/unclutter-xfixes-1.5-r1.ebuild
+++ /dev/null
@@ -1,31 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit toolchain-funcs
-
-DESCRIPTION="A rewrite of unclutter using the x11-xfixes extension"
-HOMEPAGE="https://github.com/Airblader/unclutter-xfixes"
-SRC_URI="https://github.com/Airblader/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-RDEPEND="
- dev-libs/libev
- x11-libs/libX11
- x11-libs/libXfixes
- x11-libs/libXi
- !x11-misc/unclutter
-"
-DEPEND="${RDEPEND}"
-BDEPEND="
- app-text/asciidoc
- virtual/pkgconfig
-"
-
-src_compile() {
- emake CC="$(tc-getCC)"
-}
diff --git a/x11-misc/unclutter-xfixes/unclutter-xfixes-1.5-r2.ebuild b/x11-misc/unclutter-xfixes/unclutter-xfixes-1.5-r2.ebuild
new file mode 100644
index 000000000000..7a792328069a
--- /dev/null
+++ b/x11-misc/unclutter-xfixes/unclutter-xfixes-1.5-r2.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="Hides mouse pointer while not in use (rewrite of unclutter)"
+HOMEPAGE="https://github.com/Airblader/unclutter-xfixes"
+SRC_URI="https://github.com/Airblader/unclutter-xfixes/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-libs/libev
+ x11-libs/libX11
+ x11-libs/libXfixes
+ x11-libs/libXi
+ !x11-misc/unclutter"
+DEPEND="
+ ${RDEPEND}
+ x11-base/xorg-proto"
+BDEPEND="
+ app-text/asciidoc
+ virtual/pkgconfig"
+
+src_compile() {
+ emake CC="$(tc-getCC)"
+}
+
+src_install() {
+ dobin unclutter
+ newman man/${PN}.1 unclutter.1
+ einstalldocs
+}