summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJay Faulkner <jay@jvf.cc>2022-04-21 18:58:15 -0700
committerSam James <sam@gentoo.org>2022-04-22 03:00:25 +0100
commit3496474bbc48fe59838518b04cf274c5c8b47ae7 (patch)
tree4fd2807354341c14a2ccaf8c49c28585c01a2a79 /x11-misc/revelation
parentkde-frameworks/qqc2-desktop-style: Stabilize 5.92.0 x86, #838502 (diff)
downloadgentoo-3496474bbc48fe59838518b04cf274c5c8b47ae7.tar.gz
gentoo-3496474bbc48fe59838518b04cf274c5c8b47ae7.tar.bz2
gentoo-3496474bbc48fe59838518b04cf274c5c8b47ae7.zip
x11-misc/revelation: Fix build for =>meson-0.60
Patches out a deprecated use of positional argument in i18n.merge_files to ensure build can succeed on meson 0.60 and newer. This change should not break support for meson 0.59.4, as this usage was already deprecated but only throwing warnings at that release. https://github.com/mikelolasagasti/revelation/issues/87 Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Jay Faulkner <jay@jvf.cc> Closes: https://github.com/gentoo/gentoo/pull/25146 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'x11-misc/revelation')
-rw-r--r--x11-misc/revelation/files/revelation-0.5.4-issue87-fix-meson-0.60.patch11
-rw-r--r--x11-misc/revelation/revelation-0.5.4-r1.ebuild4
2 files changed, 14 insertions, 1 deletions
diff --git a/x11-misc/revelation/files/revelation-0.5.4-issue87-fix-meson-0.60.patch b/x11-misc/revelation/files/revelation-0.5.4-issue87-fix-meson-0.60.patch
new file mode 100644
index 000000000000..4a224fc529d1
--- /dev/null
+++ b/x11-misc/revelation/files/revelation-0.5.4-issue87-fix-meson-0.60.patch
@@ -0,0 +1,11 @@
+https://github.com/mikelolasagasti/revelation/issues/87
+--- a/data/meson.build
++++ b/data/meson.build
+@@ -59,7 +59,6 @@ rvl_appstreamdir = join_paths(rvl_datadir, 'metainfo')
+
+ # Merge the translations with the appdata file
+ i18n.merge_file(
+- appdata,
+ input: appdata + '.in',
+ output: appdata,
+ po_dir: join_paths(meson.source_root(), 'po'),
diff --git a/x11-misc/revelation/revelation-0.5.4-r1.ebuild b/x11-misc/revelation/revelation-0.5.4-r1.ebuild
index 61972b294f01..ef1516172cbe 100644
--- a/x11-misc/revelation/revelation-0.5.4-r1.ebuild
+++ b/x11-misc/revelation/revelation-0.5.4-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -33,6 +33,8 @@ RDEPEND="${PYTHON_DEPS}
DEPEND="${RDEPEND}"
+PATCHES=( "${FILESDIR}"/revelation-0.5.4-issue87-fix-meson-0.60.patch )
+
src_prepare() {
find -name '*.py' -exec \
sed -i -e 's:Cryptodome:Crypto:' meson.build {} + || die