summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Jordan <immoloism@gmail.com>2023-12-22 02:09:26 +0000
committerSam James <sam@gentoo.org>2023-12-22 06:42:41 +0000
commit4ec207455f2998ebc268ed2f49e379c1d9eea254 (patch)
treeb77e8f710bb7ae2b11380d919e8640987bcbe51b /x11-misc/mate-notification-daemon
parentapp-editors/pluma: add 1.26.1 (diff)
downloadgentoo-4ec207455f2998ebc268ed2f49e379c1d9eea254.tar.gz
gentoo-4ec207455f2998ebc268ed2f49e379c1d9eea254.tar.bz2
gentoo-4ec207455f2998ebc268ed2f49e379c1d9eea254.zip
x11-misc/mate-notification-daemon: add 1.26.1
Signed-off-by: Ian Jordan <immoloism@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'x11-misc/mate-notification-daemon')
-rw-r--r--x11-misc/mate-notification-daemon/Manifest1
-rw-r--r--x11-misc/mate-notification-daemon/mate-notification-daemon-1.26.1.ebuild64
2 files changed, 65 insertions, 0 deletions
diff --git a/x11-misc/mate-notification-daemon/Manifest b/x11-misc/mate-notification-daemon/Manifest
index 3496ca1ce813..a3e9c98bc2fe 100644
--- a/x11-misc/mate-notification-daemon/Manifest
+++ b/x11-misc/mate-notification-daemon/Manifest
@@ -1,2 +1,3 @@
DIST mate-notification-daemon-1.26.0.tar.xz 421032 BLAKE2B 3f55a281cc51e63245371a1bf4ddadb2be4fa09bf16a4ffac701d4530f519a65e2ff69c7e58e6589fa923d3af86315e36d5445a6a1915a6857271933605eaaac SHA512 5249cf14ba93f2e74b9774226c5d0f5e90a517df07569e16a23af7053f5ef160afe98c8a3452baf80c243272763eee1fde0b84f434f55df1f9de26298361a1dc
+DIST mate-notification-daemon-1.26.1.tar.xz 428836 BLAKE2B 78b852f8b6f6f2cdae46831c527ccca24fddf0c12660a886e5eb1b31c1046f1fcaa64de42915038306288f6baef6071ef4347f32b5cce30e4d2488e7bdc6c6d0 SHA512 c7aaef499acb2829f9833734a57e77a11a321369cb5134a4c49bb3c1e9899951c6c3702d3aac1dff6ce1bb8e60e41fc7ac31046e3346852d2da5d4dacf849a1e
DIST mate-notification-daemon-1.27.1.tar.xz 431696 BLAKE2B 386c046c92a1b9baadeafbad8c376a6eabe3251c461ca28e7f9da0c0ec717c27c370aa854f9cc8477cfc6bb045cf5e80f813a0eda43c1dd21b1ed493acc3ede1 SHA512 280080b49185949c77396da6712d1837ddee51cad3d5e59e6a378a8e968d9738ef0d0f2161d09787a251e333d27454d2d2ff78bac5ac5c07ae5f59cf34efa86d
diff --git a/x11-misc/mate-notification-daemon/mate-notification-daemon-1.26.1.ebuild b/x11-misc/mate-notification-daemon/mate-notification-daemon-1.26.1.ebuild
new file mode 100644
index 000000000000..737071d3f840
--- /dev/null
+++ b/x11-misc/mate-notification-daemon/mate-notification-daemon-1.26.1.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MATE_LA_PUNT="yes"
+
+inherit mate
+
+MINOR=$(($(ver_cut 2) % 2))
+if [[ ${MINOR} -eq 0 ]]; then
+ KEYWORDS="~amd64 ~arm ~arm64 ~loong ~riscv ~x86"
+fi
+
+DESCRIPTION="MATE Notification daemon"
+LICENSE="GPL-2+ GPL-3+"
+SLOT="0"
+
+IUSE="nls X wayland"
+REQUIRED_USE="|| ( X wayland )"
+
+COMMON_DEPEND="
+ >=app-accessibility/at-spi2-core-2.46.0
+ >=dev-libs/glib-2.50:2
+ >=dev-libs/libxml2-2.9.0
+ >=sys-apps/dbus-1
+ x11-libs/cairo
+ >=x11-libs/gdk-pixbuf-2.22:2
+ >=x11-libs/libnotify-0.7
+ >=x11-libs/gtk+-3.22:3
+ >=media-libs/libcanberra-0.4:0[gtk3]
+ X? (
+ x11-libs/libX11
+ >=x11-libs/libwnck-3:3
+ )
+ wayland? ( gui-libs/gtk-layer-shell )
+"
+
+RDEPEND="${COMMON_DEPEND}
+ !x11-misc/notify-osd
+ !x11-misc/notification-daemon
+"
+
+DEPEND="${COMMON_DEPEND}
+ app-arch/xz-utils
+ dev-util/gdbus-codegen
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+ mate-base/mate-panel
+"
+
+src_configure() {
+ mate_src_configure \
+ $(use_enable nls) \
+ $(use_enable X x11) \
+ $(use_enable wayland)
+}
+
+src_install() {
+ mate_src_install
+
+ insinto /usr/share/dbus-1/services
+ doins "${FILESDIR}/org.freedesktop.Notifications.service"
+}