summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolić <jsmolic@gentoo.org>2021-11-05 20:06:53 +0100
committerJakov Smolić <jsmolic@gentoo.org>2021-11-06 21:32:56 +0100
commit33beb24f2049b168500ae3e948454f2d2791f794 (patch)
treeeb9ecf9dbefbd0b7257ef81674f65894c8a5d24e /x11-misc/lsw
parentsys-power/pmtools: Port to EAPI 8 (diff)
downloadgentoo-33beb24f2049b168500ae3e948454f2d2791f794.tar.gz
gentoo-33beb24f2049b168500ae3e948454f2d2791f794.tar.bz2
gentoo-33beb24f2049b168500ae3e948454f2d2791f794.zip
x11-misc/lsw: Port to EAPI 8
Closes: https://bugs.gentoo.org/819162 Signed-off-by: Jakov Smolić <jsmolic@gentoo.org>
Diffstat (limited to 'x11-misc/lsw')
-rw-r--r--x11-misc/lsw/lsw-0.3.ebuild9
1 files changed, 6 insertions, 3 deletions
diff --git a/x11-misc/lsw/lsw-0.3.ebuild b/x11-misc/lsw/lsw-0.3.ebuild
index 8d3f62603016..dc08e72ece85 100644
--- a/x11-misc/lsw/lsw-0.3.ebuild
+++ b/x11-misc/lsw/lsw-0.3.ebuild
@@ -1,7 +1,8 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=8
+
inherit toolchain-funcs
DESCRIPTION="list window names"
@@ -17,6 +18,8 @@ DEPEND="${RDEPEND}
x11-base/xorg-proto"
src_prepare() {
+ default
+
sed -i config.mk \
-e '/^CC/d' \
-e '/^CFLAGS/{s| -Os||;s|=|+=|}' \
@@ -28,7 +31,7 @@ src_prepare() {
}
src_compile() {
- emake CC=$(tc-getCC)
+ emake CC="$(tc-getCC)"
}
src_install() {