summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVladimir Pavljuchenkov (SpiderX) <spiderx@spiderx.dp.ua>2017-03-12 15:28:10 +0200
committerAmy Liffey <amynka@gentoo.org>2017-03-15 22:37:26 +0100
commit38336366d319a417a0f3d057504b5adcaea64361 (patch)
treee4062f0d6010e07d84f2204fa012624c3a59dd0c /x11-misc/libinput-gestures
parentnet-libs/rb_libtorrent: Make sure 1.1.2 links against the right version of th... (diff)
downloadgentoo-38336366d319a417a0f3d057504b5adcaea64361.tar.gz
gentoo-38336366d319a417a0f3d057504b5adcaea64361.tar.bz2
gentoo-38336366d319a417a0f3d057504b5adcaea64361.zip
x11-misc/libinput-gestures: bump to 2.19
1. Sorted USE flags alphabetically. Closes: #4191 Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'x11-misc/libinput-gestures')
-rw-r--r--x11-misc/libinput-gestures/Manifest1
-rw-r--r--x11-misc/libinput-gestures/libinput-gestures-2.19.ebuild32
-rw-r--r--x11-misc/libinput-gestures/libinput-gestures-9999.ebuild4
3 files changed, 35 insertions, 2 deletions
diff --git a/x11-misc/libinput-gestures/Manifest b/x11-misc/libinput-gestures/Manifest
index 347915af5e54..c8560be16c56 100644
--- a/x11-misc/libinput-gestures/Manifest
+++ b/x11-misc/libinput-gestures/Manifest
@@ -1 +1,2 @@
DIST libinput-gestures-2.15.tar.gz 11468 SHA256 95a91a2c7c4c9f91c035f7defb6868a92f6c61218d0fcb0a87b0fa63527c2912 SHA512 b0449ce3355e700655cf450b62e239566f2a49127bb4afeda659e04026657d86f13dbfd101399428771b92323e6c55cf40f75bad79025ff80eb9003d85345c23 WHIRLPOOL 9ff81290ecadc17bf2fbfeeb0a5ce1ff0adb059c1675f111a18144f13ac058f5efda445f139fb6158b17ec81a0b6014400d9c54fa8c393f206f4e4c71382b310
+DIST libinput-gestures-2.19.tar.gz 13031 SHA256 3f7cea70af6fc83f8d5910ef2a2a18955b0682b04c7a094ba6bcd46d912ddaaa SHA512 d67e5180e89dd1032fc16be6c6bb8b17f413bc41ebf2d92735fa444b23b5001ae37e243d1089f96308ea22a015b38c066ad8ca2a8f33feea247a51d6bf049d10 WHIRLPOOL 40d8b8715f2960454b843446548fc6106a56b21ca309089e077a2bf9ee4ea2b9ce0bc07025521de9f86851ce98a549e06baacf17923a7eb82e3424700674dbd3
diff --git a/x11-misc/libinput-gestures/libinput-gestures-2.19.ebuild b/x11-misc/libinput-gestures/libinput-gestures-2.19.ebuild
new file mode 100644
index 000000000000..766fd4ddfc59
--- /dev/null
+++ b/x11-misc/libinput-gestures/libinput-gestures-2.19.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{3_4,3_5} )
+
+inherit python-single-r1
+
+DESCRIPTION="Actions gestures on your touchpad using libinput"
+HOMEPAGE="https://github.com/bulletmark/${PN}"
+SRC_URI="https://github.com/bulletmark/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gtk kde"
+
+RDEPEND="${PYTHON_DEPS}
+ dev-libs/libinput
+ x11-misc/xdotool
+ x11-misc/wmctrl"
+DEPEND="dev-libs/libinput
+ dev-util/desktop-file-utils
+ gtk? ( x11-libs/gtk+:3 )
+ kde? ( kde-plasma/kde-cli-tools:5 )"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+pkg_postinst() {
+ elog "You must be in the input group to read the touchpad device."
+}
diff --git a/x11-misc/libinput-gestures/libinput-gestures-9999.ebuild b/x11-misc/libinput-gestures/libinput-gestures-9999.ebuild
index c52057900f6f..dd54500b3b43 100644
--- a/x11-misc/libinput-gestures/libinput-gestures-9999.ebuild
+++ b/x11-misc/libinput-gestures/libinput-gestures-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -15,7 +15,7 @@ SRC_URI=""
LICENSE="GPL-3"
SLOT="0"
KEYWORDS=""
-IUSE="kde gtk"
+IUSE="gtk kde"
RDEPEND="${PYTHON_DEPS}
dev-libs/libinput