summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2016-02-26 07:36:18 -0500
committerAnthony G. Basile <blueness@gentoo.org>2016-02-26 07:36:38 -0500
commit0cde5cef33c8cae17a2c4f96ffecc8d47422cea1 (patch)
tree370f9f4bbb3033975590202e7947eb66d43bf726 /x11-libs
parentMerge branch 'pull895' (diff)
downloadgentoo-0cde5cef33c8cae17a2c4f96ffecc8d47422cea1.tar.gz
gentoo-0cde5cef33c8cae17a2c4f96ffecc8d47422cea1.tar.bz2
gentoo-0cde5cef33c8cae17a2c4f96ffecc8d47422cea1.zip
x11-libs/gdk-pixbuf: fix build on uClibc, bug #563052
Upstream doesn't understand the proper use of __GLIBC__ and __UCLIBC__, which I am trying to convince them of. See: https://bugzilla.gnome.org/show_bug.cgi?id=756590 Package-Manager: portage-2.2.26
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/gdk-pixbuf/files/gdk-pixbuf-2.32.3-fix-lowmem-uclibc.patch34
-rw-r--r--x11-libs/gdk-pixbuf/gdk-pixbuf-2.32.3-r1.ebuild3
-rw-r--r--x11-libs/gdk-pixbuf/gdk-pixbuf-2.32.3.ebuild3
3 files changed, 40 insertions, 0 deletions
diff --git a/x11-libs/gdk-pixbuf/files/gdk-pixbuf-2.32.3-fix-lowmem-uclibc.patch b/x11-libs/gdk-pixbuf/files/gdk-pixbuf-2.32.3-fix-lowmem-uclibc.patch
new file mode 100644
index 000000000000..77ea7e75521e
--- /dev/null
+++ b/x11-libs/gdk-pixbuf/files/gdk-pixbuf-2.32.3-fix-lowmem-uclibc.patch
@@ -0,0 +1,34 @@
+From 21b8eb73d9272e06707ad6d0357f3034b8d9a46f Mon Sep 17 00:00:00 2001
+From: "Anthony G. Basile" <blueness@gentoo.org>
+Date: Wed, 14 Oct 2015 16:18:19 -0400
+Subject: [PATCH] tests/pixbuf-lowmem.c: Do not run pixbuf-lowmem test on
+ uClibc
+
+pixbuf-lowmem.c depends on GNU libc internals and does not build
+on musl or uClibc. Commit e1fd25a fixes this issue for musl by
+testing if __GLIBC__ is set. However, uClibc sets __GLIBC__ and
+so this check is insufficient there. We expand the check so that
+we run pixbuf-lowmem on glibc, while avoiding it on both musl and
+uClibc.
+
+Signed-off-by: Anthony G. Basile <blueness@gentoo.org>
+---
+ tests/pixbuf-lowmem.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/tests/pixbuf-lowmem.c b/tests/pixbuf-lowmem.c
+index 9e9571f..ec7504f 100644
+--- a/tests/pixbuf-lowmem.c
++++ b/tests/pixbuf-lowmem.c
+@@ -24,7 +24,7 @@
+ #include <time.h>
+ #include <string.h>
+
+-#ifdef __GLIBC__
++#if defined(__GLIBC__) && !defined(__UCLIBC__)
+ #define PRETEND_MEM_SIZE (16 * 1024 * 1024)
+ #define REMAINING_MEM_SIZE 100000
+
+--
+2.4.9
+
diff --git a/x11-libs/gdk-pixbuf/gdk-pixbuf-2.32.3-r1.ebuild b/x11-libs/gdk-pixbuf/gdk-pixbuf-2.32.3-r1.ebuild
index a8fa23988b1b..5ca298a56ad7 100644
--- a/x11-libs/gdk-pixbuf/gdk-pixbuf-2.32.3-r1.ebuild
+++ b/x11-libs/gdk-pixbuf/gdk-pixbuf-2.32.3-r1.ebuild
@@ -43,6 +43,9 @@ MULTILIB_CHOST_TOOLS=(
)
src_prepare() {
+ # See https://bugzilla.gnome.org/show_bug.cgi?id=756590
+ epatch "${FILESDIR}"/${PN}-2.32.3-fix-lowmem-uclibc.patch
+
# This will avoid polluting the pkg-config file with versioned libpng,
# which is causing problems with libpng14 -> libpng15 upgrade
# See upstream bug #667068
diff --git a/x11-libs/gdk-pixbuf/gdk-pixbuf-2.32.3.ebuild b/x11-libs/gdk-pixbuf/gdk-pixbuf-2.32.3.ebuild
index 27a8968bf53e..b7f65978e990 100644
--- a/x11-libs/gdk-pixbuf/gdk-pixbuf-2.32.3.ebuild
+++ b/x11-libs/gdk-pixbuf/gdk-pixbuf-2.32.3.ebuild
@@ -43,6 +43,9 @@ MULTILIB_CHOST_TOOLS=(
)
src_prepare() {
+ # See https://bugzilla.gnome.org/show_bug.cgi?id=756590
+ epatch "${FILESDIR}"/${PN}-2.32.3-fix-lowmem-uclibc.patch
+
# This will avoid polluting the pkg-config file with versioned libpng,
# which is causing problems with libpng14 -> libpng15 upgrade
# See upstream bug #667068