summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-libs/libsexy
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-libs/libsexy')
-rw-r--r--x11-libs/libsexy/Manifest1
-rw-r--r--x11-libs/libsexy/files/libsexy-0.1.11-fix-null-list.patch34
-rw-r--r--x11-libs/libsexy/files/libsexy-0.1.11-pkgconfig-pollution.patch12
-rw-r--r--x11-libs/libsexy/libsexy-0.1.11-r3.ebuild54
-rw-r--r--x11-libs/libsexy/libsexy-0.1.11-r4.ebuild58
-rw-r--r--x11-libs/libsexy/metadata.xml5
6 files changed, 164 insertions, 0 deletions
diff --git a/x11-libs/libsexy/Manifest b/x11-libs/libsexy/Manifest
new file mode 100644
index 000000000000..48bfa7b71803
--- /dev/null
+++ b/x11-libs/libsexy/Manifest
@@ -0,0 +1 @@
+DIST libsexy-0.1.11.tar.bz2 267376 SHA256 ba113ff5148e9ac137381a1da7045caa750a3b0c0113d4b97549bdbb6c1c8bb6 SHA512 60c7f1e8891ae36ab1f7a5b3421b1819bd940470d226b9e6dd752c4ec63ca79b5f8589c0cdd818f1c72e2bff605572554a537750be5774c6752df6bae99d094a WHIRLPOOL 069ecdaf69bff37810ee80e49b45d49ea0ef4cc2610976516ac71e54550876dfdc737599f763fe4ecd17f2b10a0a51e5a7574a697fc857ba26ff9a047e75c494
diff --git a/x11-libs/libsexy/files/libsexy-0.1.11-fix-null-list.patch b/x11-libs/libsexy/files/libsexy-0.1.11-fix-null-list.patch
new file mode 100644
index 000000000000..5330e12e3a57
--- /dev/null
+++ b/x11-libs/libsexy/files/libsexy-0.1.11-fix-null-list.patch
@@ -0,0 +1,34 @@
+diff -Nur libsexy-0.1.11/libsexy/sexy-spell-entry.c libsexy-0.1.11_patched/libsexy/sexy-spell-entry.c
+--- libsexy-0.1.11/libsexy/sexy-spell-entry.c 2006-08-17 21:11:09.000000000 +0300
++++ libsexy-0.1.11_patched/libsexy/sexy-spell-entry.c 2009-05-17 15:15:25.000000000 +0300
+@@ -56,7 +56,7 @@
+ static void (*enchant_dict_add_to_session) (struct EnchantDict * dict, const char *const word, ssize_t len);
+ static int (*enchant_dict_check) (struct EnchantDict * dict, const char *const word, ssize_t len);
+ static void (*enchant_dict_describe) (struct EnchantDict * dict, EnchantDictDescribeFn fn, void * user_data);
+-static void (*enchant_dict_free_suggestions) (struct EnchantDict * dict, char **suggestions);
++static void (*enchant_dict_free_string_list) (struct EnchantDict * dict, char **suggestions);
+ static void (*enchant_dict_store_replacement) (struct EnchantDict * dict, const char *const mis, ssize_t mis_len, const char *const cor, ssize_t cor_len);
+ static char ** (*enchant_dict_suggest) (struct EnchantDict * dict, const char *const word, ssize_t len, size_t * out_n_suggs);
+ static gboolean have_enchant = FALSE;
+@@ -156,8 +156,8 @@
+ MODULE_SYMBOL("enchant_dict_add_to_session", enchant_dict_add_to_session)
+ MODULE_SYMBOL("enchant_dict_check", enchant_dict_check)
+ MODULE_SYMBOL("enchant_dict_describe", enchant_dict_describe)
+- MODULE_SYMBOL("enchant_dict_free_suggestions",
+- enchant_dict_free_suggestions)
++ MODULE_SYMBOL("enchant_dict_free_string_list",
++ enchant_dict_free_string_list)
+ MODULE_SYMBOL("enchant_dict_store_replacement",
+ enchant_dict_store_replacement)
+ MODULE_SYMBOL("enchant_dict_suggest", enchant_dict_suggest)
+@@ -435,9 +435,8 @@
+ gtk_widget_show(mi);
+ gtk_menu_shell_append(GTK_MENU_SHELL(menu), mi);
+ }
++ enchant_dict_free_string_list(dict, suggestions);
+ }
+-
+- enchant_dict_free_suggestions(dict, suggestions);
+ }
+
+ static GtkWidget *
diff --git a/x11-libs/libsexy/files/libsexy-0.1.11-pkgconfig-pollution.patch b/x11-libs/libsexy/files/libsexy-0.1.11-pkgconfig-pollution.patch
new file mode 100644
index 000000000000..faf16dea71ca
--- /dev/null
+++ b/x11-libs/libsexy/files/libsexy-0.1.11-pkgconfig-pollution.patch
@@ -0,0 +1,12 @@
+--- libsexy.pc.in
++++ libsexy.pc.in
+@@ -6,7 +6,8 @@
+ Name: libsexy
+ Description: Doing naughty things to good widgets
+ Version: @VERSION@
+-Libs: -L${libdir} -lsexy @PACKAGE_LIBS@
++Libs: -L${libdir} -lsexy
++Libs.private: @PACKAGE_LIBS@
+ Cflags: -I${includedir} @PACKAGE_CFLAGS@
+
+
diff --git a/x11-libs/libsexy/libsexy-0.1.11-r3.ebuild b/x11-libs/libsexy/libsexy-0.1.11-r3.ebuild
new file mode 100644
index 000000000000..1b15dcc8394d
--- /dev/null
+++ b/x11-libs/libsexy/libsexy-0.1.11-r3.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit autotools eutils
+
+DESCRIPTION="Sexy GTK+ Widgets"
+HOMEPAGE="http://www.chipx86.com/wiki/Libsexy"
+SRC_URI="http://releases.chipx86.com/${PN}/${PN}/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 sh sparc x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
+IUSE="doc static-libs"
+
+RDEPEND=">=dev-libs/glib-2
+ >=x11-libs/gtk+-2.20:2
+ dev-libs/libxml2
+ >=x11-libs/pango-1.4
+ >=app-text/iso-codes-0.49"
+DEPEND="${RDEPEND}
+ >=dev-lang/perl-5
+ virtual/pkgconfig
+ dev-util/gtk-doc-am
+ doc? ( >=dev-util/gtk-doc-1.4 )"
+
+DOCS="AUTHORS ChangeLog NEWS"
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${P}-fix-null-list.patch \
+ "${FILESDIR}"/${P}-pkgconfig-pollution.patch
+
+ sed -i \
+ -e 's:noinst_PROGRAMS:check_PROGRAMS:' \
+ tests/Makefile.am || die
+
+ rm -f acinclude.m4 #420913
+
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable static-libs static) \
+ $(use_enable doc gtk-doc) \
+ --with-html-dir="${EPREFIX}"/usr/share/doc/${PF}/html
+}
+
+src_install() {
+ default
+ prune_libtool_files
+}
diff --git a/x11-libs/libsexy/libsexy-0.1.11-r4.ebuild b/x11-libs/libsexy/libsexy-0.1.11-r4.ebuild
new file mode 100644
index 000000000000..ad786dcccffb
--- /dev/null
+++ b/x11-libs/libsexy/libsexy-0.1.11-r4.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+AUTOTOOLS_AUTORECONF=true
+
+inherit autotools-utils
+
+DESCRIPTION="Sexy GTK+ Widgets"
+HOMEPAGE="http://www.chipx86.com/wiki/Libsexy"
+SRC_URI="http://releases.chipx86.com/${PN}/${PN}/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
+IUSE="doc static-libs"
+
+RDEPEND=">=dev-libs/glib-2
+ >=x11-libs/gtk+-2.20:2
+ dev-libs/libxml2
+ >=x11-libs/pango-1.4
+ >=app-text/iso-codes-0.49"
+DEPEND="${RDEPEND}
+ >=dev-lang/perl-5
+ virtual/pkgconfig
+ dev-util/gtk-doc-am
+ doc? ( >=dev-util/gtk-doc-1.4 )"
+
+DOCS=( AUTHORS ChangeLog NEWS )
+
+PATCHES=(
+ "${FILESDIR}"/${P}-fix-null-list.patch
+ "${FILESDIR}"/${P}-pkgconfig-pollution.patch
+ )
+
+src_prepare() {
+ sed -i \
+ -e 's:noinst_PROGRAMS:check_PROGRAMS:' \
+ tests/Makefile.am || die
+
+ rm -f acinclude.m4 #420913
+
+ sed \
+ -e "s:AM_CONFIG_HEADER:AC_CONFIG_HEADERS:g" \
+ -i configure.ac
+
+ autotools-utils_src_prepare
+}
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable doc gtk-doc)
+ --with-html-dir="${EPREFIX}/usr/share/doc/${PF}/html"
+ )
+ autotools-utils_src_configure
+}
diff --git a/x11-libs/libsexy/metadata.xml b/x11-libs/libsexy/metadata.xml
new file mode 100644
index 000000000000..2953eb8e0471
--- /dev/null
+++ b/x11-libs/libsexy/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>freedesktop</herd>
+</pkgmetadata>