summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2022-03-30 13:59:20 -0700
committerMatt Turner <mattst88@gentoo.org>2022-03-30 14:02:19 -0700
commit0d3d90c8a98363ebd13d172520a8cf11a5d0c078 (patch)
tree057805621cd60f8d79647e8628c454af4a08b2ab /x11-libs/libX11
parentx11-misc/compose-tables: Version bump to 1.7.4 (diff)
downloadgentoo-0d3d90c8a98363ebd13d172520a8cf11a5d0c078.tar.gz
gentoo-0d3d90c8a98363ebd13d172520a8cf11a5d0c078.tar.bz2
gentoo-0d3d90c8a98363ebd13d172520a8cf11a5d0c078.zip
x11-libs/libX11: Version bump to 1.7.4
Closes: https://bugs.gentoo.org/832986 Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'x11-libs/libX11')
-rw-r--r--x11-libs/libX11/Manifest1
-rw-r--r--x11-libs/libX11/libX11-1.7.4.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/x11-libs/libX11/Manifest b/x11-libs/libX11/Manifest
index a285fd2d4009..3e839d0160ac 100644
--- a/x11-libs/libX11/Manifest
+++ b/x11-libs/libX11/Manifest
@@ -1 +1,2 @@
DIST libX11-1.7.3.tar.xz 1861304 BLAKE2B e0f647ef55567b1d7eff74bc053b8e73f8c696be6f233c2ff6f64dee65c1b40b746683ea7a6fafb4304eba4dec43301b4b3506e2ec6fac1d4c89d664b516bbdd SHA512 abc70837d19f7e104a5db1e6d2cfa1256625332c0b53fec44a0a39916a60a430bb53fd436207892aabe4199ac7a0f9287a06588fcd27e0eed54d45d67bbe1294
+DIST libX11-1.7.4.tar.xz 1872992 BLAKE2B 6a25e5008ead53be5af7411f51711789eb410473f9aefc49fb4d0bf7227b89c5fd71f0f61fef9bc3f83e585e4815644f42884d5e5cf0bdcdd120abe6fe8a741b SHA512 8bfaaf9fc3081c47152d533d30cdc0b2521bfeb088ff813b041c08ffd518c80ba3725bb68cac7c21b521a4bace546f99424700fe21955b498015d14c2f7f9a57
diff --git a/x11-libs/libX11/libX11-1.7.4.ebuild b/x11-libs/libX11/libX11-1.7.4.ebuild
new file mode 100644
index 000000000000..34171b8bc0c2
--- /dev/null
+++ b/x11-libs/libX11/libX11-1.7.4.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+XORG_DOC=doc
+XORG_MULTILIB=yes
+XORG_TARBALL_SUFFIX=xz
+inherit toolchain-funcs xorg-3
+
+# Note: please bump this with x11-misc/compose-tables
+DESCRIPTION="X.Org X11 library"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
+IUSE="ipv6 test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=x11-libs/libxcb-1.11.1[${MULTILIB_USEDEP}]
+ x11-misc/compose-tables"
+DEPEND="${RDEPEND}
+ x11-base/xorg-proto
+ x11-libs/xtrans"
+BDEPEND="test? ( dev-lang/perl )"
+
+src_configure() {
+ local XORG_CONFIGURE_OPTIONS=(
+ $(use_with doc xmlto)
+ $(use_enable doc specs)
+ $(use_enable ipv6)
+ --without-fop
+ CPP="$(tc-getPROG CPP cpp)"
+ )
+ xorg-3_src_configure
+}
+
+src_install() {
+ xorg-3_src_install
+ rm -rf "${ED}"/usr/share/X11/locale || die
+}