summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-12-09 16:41:22 +0000
committerSam James <sam@gentoo.org>2023-12-09 18:06:01 +0000
commitf2a3ca63e369a64bc0e3ec97c1958eb86b5c71de (patch)
treefb397fa496db705f47f582baa704c49f699b241e /x11-apps
parentx11-apps/xdm: fix modern C issue (diff)
downloadgentoo-f2a3ca63e369a64bc0e3ec97c1958eb86b5c71de.tar.gz
gentoo-f2a3ca63e369a64bc0e3ec97c1958eb86b5c71de.tar.bz2
gentoo-f2a3ca63e369a64bc0e3ec97c1958eb86b5c71de.zip
x11-apps/xkbutils: fix modern C issue
Closes: https://bugs.gentoo.org/919190 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'x11-apps')
-rw-r--r--x11-apps/xkbutils/files/xkbutils-1.0.5-c99.patch43
-rw-r--r--x11-apps/xkbutils/xkbutils-1.0.5-r1.ebuild22
2 files changed, 65 insertions, 0 deletions
diff --git a/x11-apps/xkbutils/files/xkbutils-1.0.5-c99.patch b/x11-apps/xkbutils/files/xkbutils-1.0.5-c99.patch
new file mode 100644
index 000000000000..c396361762a1
--- /dev/null
+++ b/x11-apps/xkbutils/files/xkbutils-1.0.5-c99.patch
@@ -0,0 +1,43 @@
+https://bugs.gentoo.org/919190
+https://gitlab.freedesktop.org/xorg/app/xkbutils/-/issues/2
+https://gitlab.freedesktop.org/xorg/app/xkbutils/-/merge_requests/4
+
+From 5f875c8a6bc12d47ad655ba820031bb917f321c0 Mon Sep 17 00:00:00 2001
+From: Alan Coopersmith <alan.coopersmith@oracle.com>
+Date: Tue, 5 Dec 2023 15:01:42 -0800
+Subject: [PATCH 3/3] xkbwatch: Fix -Wincompatible-pointer-types warning (Issue
+ #2)
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+Fixes warning from gcc 13 that is becoming an error in gcc 14
+
+xkbwatch.c:92:34: warning: passing argument 7 of ‘XtOpenApplication’
+ from incompatible pointer type [-Wincompatible-pointer-types]
+ 92 | fallback_resources,
+ | ^~~~~~~~~~~~~~~~~~
+ | |
+ | char **
+In file included from xkbwatch.c:31:
+.../X11/Intrinsic.h:1473:5: note: expected ‘const char **’ but
+ argument is of type ‘char **’
+ 1473 | String* /* fallback_resources */,
+ | ^~~~~~~
+
+Closes: #2
+Signed-off-by: Alan Coopersmith <alan.coopersmith@oracle.com>
+--- a/xkbwatch.c
++++ b/xkbwatch.c
+@@ -72,7 +72,7 @@ main(int argc, char *argv[])
+ static Arg vArgs[] = { {XtNorientation, (XtArgVal) XtorientVertical} };
+ static Arg onArgs[] = { {XtNon, (XtArgVal) True} };
+ static Arg offArgs[] = { {XtNon, (XtArgVal) False} };
+- static char *fallback_resources[] = {
++ static String fallback_resources[] = {
+ "*Box*background: grey50",
+ "*Box*borderWidth: 0",
+ "*Box*vSpace: 1",
+--
+GitLab
+
diff --git a/x11-apps/xkbutils/xkbutils-1.0.5-r1.ebuild b/x11-apps/xkbutils/xkbutils-1.0.5-r1.ebuild
new file mode 100644
index 000000000000..8c507f49ed57
--- /dev/null
+++ b/x11-apps/xkbutils/xkbutils-1.0.5-r1.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+XORG_TARBALL_SUFFIX="xz"
+inherit xorg-3
+
+DESCRIPTION="X.Org xkbutils application"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ x11-libs/libX11
+ x11-libs/libXt
+ x11-libs/libXaw"
+DEPEND="${RDEPEND}
+ x11-base/xorg-proto"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.0.5-c99.patch
+)