summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-06-12 21:05:08 +0200
committerMichał Górny <mgorny@gentoo.org>2020-06-12 21:31:58 +0200
commit0d8eedf503c10b13a8f35ce211efd907ebcf56bb (patch)
tree3fcc2eb6ce6f2a1078f943a4bd372e1305a9a705 /www-servers/gunicorn/gunicorn-20.0.4.ebuild
parentdev-java/swt/swt: set minimum dep on jdk to 1.8 (diff)
downloadgentoo-0d8eedf503c10b13a8f35ce211efd907ebcf56bb.tar.gz
gentoo-0d8eedf503c10b13a8f35ce211efd907ebcf56bb.tar.bz2
gentoo-0d8eedf503c10b13a8f35ce211efd907ebcf56bb.zip
www-servers/gunicorn: Bump to 20.0.4
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'www-servers/gunicorn/gunicorn-20.0.4.ebuild')
-rw-r--r--www-servers/gunicorn/gunicorn-20.0.4.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/www-servers/gunicorn/gunicorn-20.0.4.ebuild b/www-servers/gunicorn/gunicorn-20.0.4.ebuild
new file mode 100644
index 000000000000..1c881d642a18
--- /dev/null
+++ b/www-servers/gunicorn/gunicorn-20.0.4.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{6..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="A WSGI HTTP Server for UNIX"
+HOMEPAGE="https://gunicorn.org https://pypi.org/project/gunicorn https://github.com/benoitc/gunicorn"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT PSF-2 doc? ( BSD )"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="dev-python/setproctitle[${PYTHON_USEDEP}]"
+
+DOCS="README.rst"
+
+distutils_enable_sphinx 'docs/source' --no-autodoc
+distutils_enable_tests pytest
+
+src_prepare() {
+ sed -e 's:--cov=gunicorn --cov-report=xml::' -i setup.cfg || die
+ distutils-r1_src_prepare
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/source/_build/html/. )
+
+ distutils-r1_python_install_all
+}