summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sautier.louis@gmail.com>2016-01-20 13:07:17 +0100
committerLouis Sautier <sautier.louis@gmail.com>2016-01-20 13:07:17 +0100
commita9b286d055c023439f3bfc921c4d22b8a2195525 (patch)
tree7fe5bba2aa94ea09e26d24be0bf81274f7be4505 /www-misc
parentdev-python/minidb: new dep required by www-misc/urlwatch-2.0 (diff)
downloadgentoo-a9b286d055c023439f3bfc921c4d22b8a2195525.tar.gz
gentoo-a9b286d055c023439f3bfc921c4d22b8a2195525.tar.bz2
gentoo-a9b286d055c023439f3bfc921c4d22b8a2195525.zip
www-misc/urlwatch: add missing deps, drop python 2
Package-Manager: portage-2.2.27
Diffstat (limited to 'www-misc')
-rw-r--r--www-misc/urlwatch/urlwatch-2.0-r1.ebuild37
-rw-r--r--www-misc/urlwatch/urlwatch-2.0.ebuild21
2 files changed, 37 insertions, 21 deletions
diff --git a/www-misc/urlwatch/urlwatch-2.0-r1.ebuild b/www-misc/urlwatch/urlwatch-2.0-r1.ebuild
new file mode 100644
index 000000000000..03a7bd57440b
--- /dev/null
+++ b/www-misc/urlwatch/urlwatch-2.0-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+PYTHON_COMPAT=( python{3_4,3_5} )
+
+inherit distutils-r1
+
+DESCRIPTION="A tool for monitoring webpages for updates"
+HOMEPAGE="http://thp.io/2008/urlwatch/ https://pypi.python.org/pypi/urlwatch"
+SRC_URI="http://thp.io/2008/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+# https://github.com/thp/urlwatch/issues/34
+RESTRICT="test"
+
+RDEPEND="
+ virtual/python-futures[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/minidb[${PYTHON_USEDEP}]
+ || ( www-client/lynx app-text/html2text )
+"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ ${RDEPEND}
+ dev-python/nose[${PYTHON_USEDEP}]
+ )
+"
+
+python_test() {
+ nosetests test || die "tests failed with ${EPYTHON}"
+}
diff --git a/www-misc/urlwatch/urlwatch-2.0.ebuild b/www-misc/urlwatch/urlwatch-2.0.ebuild
deleted file mode 100644
index 62dca57f3eab..000000000000
--- a/www-misc/urlwatch/urlwatch-2.0.ebuild
+++ /dev/null
@@ -1,21 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI="5"
-PYTHON_COMPAT=( python{2_7,3_3,3_4} )
-
-inherit distutils-r1
-
-DESCRIPTION="A tool for monitoring webpages for updates"
-HOMEPAGE="http://thp.io/2008/urlwatch/ https://pypi.python.org/pypi/urlwatch"
-SRC_URI="http://thp.io/2008/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-DEPEND="virtual/python-futures[${PYTHON_USEDEP}]"
-RDEPEND="${DEPEND}
- || ( www-client/lynx app-text/html2text )"