summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJorge Manuel B. S. Vicetto (jmbsvicetto) <jmbsvicetto@gentoo.org>2017-11-06 16:49:25 -0100
committerJorge Manuel B. S. Vicetto (jmbsvicetto) <jmbsvicetto@gentoo.org>2017-11-06 18:01:32 -0100
commit0494563914cc7ab31e9b92f44a08452cc1121418 (patch)
tree693985bccb76f9bfee14b50bf467a2dce86c6b04 /www-apps
parentdev-php/PEAR-PHP_Debug: Drop old revision (diff)
downloadgentoo-0494563914cc7ab31e9b92f44a08452cc1121418.tar.gz
gentoo-0494563914cc7ab31e9b92f44a08452cc1121418.tar.bz2
gentoo-0494563914cc7ab31e9b92f44a08452cc1121418.zip
www-apps/drupal: Add 8.4.2 release.
Package-Manager: Portage-2.3.13, Repoman-2.3.4
Diffstat (limited to 'www-apps')
-rw-r--r--www-apps/drupal/Manifest1
-rw-r--r--www-apps/drupal/drupal-8.4.2.ebuild86
2 files changed, 87 insertions, 0 deletions
diff --git a/www-apps/drupal/Manifest b/www-apps/drupal/Manifest
index b077ec5284dd..346b3b37733b 100644
--- a/www-apps/drupal/Manifest
+++ b/www-apps/drupal/Manifest
@@ -1,2 +1,3 @@
DIST drupal-7.56.tar.gz 3277833 SHA256 02fb4b46060d53c2f876d2381a8741249819e3a02ea1d7291036f6ea280d7b69 SHA512 ab7ad8d9cb26e89b9d81280b1677584072db627d508ccade9442c95a90f24c94d11561013c8a7297ddae6ae43696d0b711b8c37ab98f89539f6f0e0154db6344 WHIRLPOOL fda209ecaf63d32cb665b31dc1aff994d0fea7ac542df331efff8c05e006a77463e7a420a1b1f8c9bffb375cf963db745e354ad5585cf4aa2ec92da68ed53352
DIST drupal-8.3.7.tar.gz 12739663 SHA256 0a86d82878500f8512a624fb13736ddf82a1c8f424d9a45776ce6b10d560eeab SHA512 d454a51b2bc7ffbad3e461df1d2ea1f38797716b046a520ad65fab5f5c398091b28bc623d3efc2d18176e6506a95e113e1d5e5a0a76e50ca7f22a995920ea671 WHIRLPOOL 9ea7653dfd117f7552a12fdcbe96556a8a2cfe1e4bdc7386aff8882f8e43a9d3a097fd3ec98d0a77ab6d19079ecf1b09c8617cf8d69198f968a0fbe09dfd0dc8
+DIST drupal-8.4.2.tar.gz 13393043 SHA256 48422be6775140e712acaa3681a1bad0cc2655e9fb7c9c754c3e6eb8bee17783 SHA512 ce4ba105c253669ed18656d50a172d2f0622b1be121895486b2df00dfda0f71c497277cbc3e3a7a9fb426b9fb0828bfcf7ede3ff134304ca136ed689d4f15582 WHIRLPOOL e0e631f860e3bac97ffd20941128c432e1b3bb143c6f05e24254ffa82a9641d8725352c9fb5333b6d303d991dd755b0d832c9a1f5aaab7fab83f44796a2dd5c5
diff --git a/www-apps/drupal/drupal-8.4.2.ebuild b/www-apps/drupal/drupal-8.4.2.ebuild
new file mode 100644
index 000000000000..d0f9fcc2d95e
--- /dev/null
+++ b/www-apps/drupal/drupal-8.4.2.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit webapp
+
+MY_PV=${PV:0:3}.0
+MY_P=${P/_/-}
+S="${WORKDIR}/${MY_P}"
+
+DESCRIPTION="PHP-based open-source platform and content management system"
+HOMEPAGE="https://www.drupal.org/"
+SRC_URI="https://ftp.drupal.org/files/projects/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~ppc ~x86"
+IUSE="+accelerator +mysql postgres sqlite +uploadprogress"
+
+RDEPEND="
+ dev-lang/php[gd,hash,pdo,postgres?,simplexml,xml]
+ virtual/httpd-php
+ accelerator? ( ||
+ (
+ dev-php/xcache
+ (
+ >=dev-lang/php-5.5[opcache]
+ dev-php/pecl-apcu
+ )
+ )
+ )
+ uploadprogress? ( dev-php/pecl-uploadprogress )
+ mysql? (
+ || (
+ dev-lang/php[mysql]
+ dev-lang/php[mysqli]
+ )
+ )
+ sqlite? ( dev-lang/php[sqlite] )
+"
+
+need_httpd_cgi
+
+REQUIRED_USE="|| ( mysql postgres sqlite )"
+
+src_install() {
+ webapp_src_preinst
+
+ local docs="LICENSE.txt README.txt core/MAINTAINERS.txt core/INSTALL.txt core/CHANGELOG.txt \
+ core/INSTALL.mysql.txt core/INSTALL.pgsql.txt core/INSTALL.sqlite.txt core/UPDATE.txt "
+
+ dodoc ${docs}
+ rm -f ${docs} core/INSTALL core/COPYRIGHT.txt core/LICENSE.txt || die
+
+ cp sites/default/{default.settings.php,settings.php} || die
+ insinto "${MY_HTDOCSDIR}"
+ doins -r .
+
+ dodir "${MY_HTDOCSDIR}"/files
+ webapp_serverowned "${MY_HTDOCSDIR}"/files
+ webapp_serverowned "${MY_HTDOCSDIR}"/sites/default
+ webapp_serverowned "${MY_HTDOCSDIR}"/sites/default/settings.php
+
+ webapp_configfile "${MY_HTDOCSDIR}"/sites/default/settings.php
+ webapp_configfile "${MY_HTDOCSDIR}"/.htaccess
+
+ webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
+
+ webapp_src_install
+}
+
+pkg_postinst() {
+ echo
+ ewarn "SECURITY NOTICE"
+ ewarn "If you plan on using SSL on your Drupal site, please consult the postinstall information:"
+ ewarn "\t# webapp-config --show-postinst ${PN} ${PV}"
+ echo
+ ewarn "If this is a new install, unless you want anyone with network access to your server to be"
+ ewarn "able to run the setup, you'll have to configure your web server to limit access to it."
+ echo
+ ewarn "If you're doing a new drupal-8 install, you'll have to copy /sites/default/default.services.yml"
+ ewarn "to /sites/default/services.yml and grant it write permissions to your web server."
+ ewarn "Just follow the instructions of the drupal setup and be sure to resolve any permissions issue"
+ ewarn "reported by the setup."
+ echo
+}