summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2019-10-14 23:01:02 +0200
committerBernard Cafarelli <voyageur@gentoo.org>2019-10-14 23:04:02 +0200
commitc7fc7edc53c6d7cab4a2607769577f0197c1a259 (patch)
tree9706c45d525cf03b3628e6aa3050bb4908b09ac4 /www-apps/piwigo/piwigo-2.10.1.ebuild
parentapp-emulation/free42: 2.5.10 bump (diff)
downloadgentoo-c7fc7edc53c6d7cab4a2607769577f0197c1a259.tar.gz
gentoo-c7fc7edc53c6d7cab4a2607769577f0197c1a259.tar.bz2
gentoo-c7fc7edc53c6d7cab4a2607769577f0197c1a259.zip
www-apps/piwigo: 2.10.1 bump
Package-Manager: Portage-2.3.76, Repoman-2.3.17 Signed-off-by: Bernard Cafarelli <voyageur@gentoo.org>
Diffstat (limited to 'www-apps/piwigo/piwigo-2.10.1.ebuild')
-rw-r--r--www-apps/piwigo/piwigo-2.10.1.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/www-apps/piwigo/piwigo-2.10.1.ebuild b/www-apps/piwigo/piwigo-2.10.1.ebuild
new file mode 100644
index 000000000000..56866abb3045
--- /dev/null
+++ b/www-apps/piwigo/piwigo-2.10.1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit webapp
+
+DESCRIPTION="a photo gallery software for the web"
+HOMEPAGE="http://piwigo.org/"
+SRC_URI="http://piwigo.org/download/dlcounter.php?code=${PV} -> ${P}.zip"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+IUSE="+exif +gd imagemagick"
+
+DEPEND=""
+RDEPEND="
+ imagemagick? ( virtual/imagemagick-tools )
+ dev-lang/php[ctype,exif?,gd?,filter,iconv,json,mysqli]
+ >=virtual/mysql-5.0
+ virtual/httpd-php"
+
+REQUIRED_USE="|| ( gd imagemagick )"
+
+S=${WORKDIR}/${PN}
+
+src_install() {
+ webapp_src_preinst
+
+ insinto "${MY_HTDOCSDIR}"
+ doins -r .
+
+ # Local configuration, and parts that can be updated
+ webapp_serverowned "${MY_HTDOCSDIR}"/_data
+ webapp_serverowned -R "${MY_HTDOCSDIR}"/galleries
+ webapp_serverowned -R "${MY_HTDOCSDIR}"/language
+ webapp_serverowned -R "${MY_HTDOCSDIR}"/local
+ webapp_serverowned -R "${MY_HTDOCSDIR}"/plugins
+ webapp_serverowned -R "${MY_HTDOCSDIR}"/template-extension
+ webapp_serverowned -R "${MY_HTDOCSDIR}"/themes
+ webapp_serverowned "${MY_HTDOCSDIR}"/upload
+
+ webapp_src_install
+}