summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2021-05-19 10:21:45 +0200
committerBernard Cafarelli <voyageur@gentoo.org>2021-05-19 12:06:01 +0200
commit4cf85216ff23071c8a6714c58ed5d6b5e1c67e70 (patch)
tree4e2ca3c578425be1f4ee68f62d3bd91194f5e8a9 /www-apps/piwigo/piwigo-11.5.0.ebuild
parentdev-python/typed-ast: sparc stable wrt bug #790962 (diff)
downloadgentoo-4cf85216ff23071c8a6714c58ed5d6b5e1c67e70.tar.gz
gentoo-4cf85216ff23071c8a6714c58ed5d6b5e1c67e70.tar.bz2
gentoo-4cf85216ff23071c8a6714c58ed5d6b5e1c67e70.zip
www-apps/piwigo: 11.5.0 version bump
Drop previous version for security bug Bug: https://bugs.gentoo.org/790728 Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Bernard Cafarelli <voyageur@gentoo.org>
Diffstat (limited to 'www-apps/piwigo/piwigo-11.5.0.ebuild')
-rw-r--r--www-apps/piwigo/piwigo-11.5.0.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/www-apps/piwigo/piwigo-11.5.0.ebuild b/www-apps/piwigo/piwigo-11.5.0.ebuild
new file mode 100644
index 000000000000..978f3b237a3f
--- /dev/null
+++ b/www-apps/piwigo/piwigo-11.5.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit webapp
+
+DESCRIPTION="a photo gallery software for the web"
+HOMEPAGE="http://piwigo.org/"
+SRC_URI="http://piwigo.org/download/dlcounter.php?code=${PV} -> ${P}.zip"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+IUSE="+exif +gd imagemagick"
+
+DEPEND=""
+RDEPEND="
+ imagemagick? ( virtual/imagemagick-tools )
+ dev-lang/php[ctype,exif?,gd?,filter,iconv,json,mysqli]
+ >=virtual/mysql-5.0
+ virtual/httpd-php"
+BDEPEND="app-arch/unzip"
+
+REQUIRED_USE="|| ( gd imagemagick )"
+
+S=${WORKDIR}/${PN}
+
+src_install() {
+ webapp_src_preinst
+
+ insinto "${MY_HTDOCSDIR}"
+ doins -r .
+
+ # Local configuration, and parts that can be updated
+ webapp_serverowned "${MY_HTDOCSDIR}"/_data
+ webapp_serverowned -R "${MY_HTDOCSDIR}"/galleries
+ webapp_serverowned -R "${MY_HTDOCSDIR}"/language
+ webapp_serverowned -R "${MY_HTDOCSDIR}"/local
+ webapp_serverowned -R "${MY_HTDOCSDIR}"/plugins
+ webapp_serverowned -R "${MY_HTDOCSDIR}"/template-extension
+ webapp_serverowned -R "${MY_HTDOCSDIR}"/themes
+ webapp_serverowned "${MY_HTDOCSDIR}"/upload
+
+ webapp_src_install
+}