summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /www-apps/dspam-web/dspam-web-3.10.1.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'www-apps/dspam-web/dspam-web-3.10.1.ebuild')
-rw-r--r--www-apps/dspam-web/dspam-web-3.10.1.ebuild71
1 files changed, 71 insertions, 0 deletions
diff --git a/www-apps/dspam-web/dspam-web-3.10.1.ebuild b/www-apps/dspam-web/dspam-web-3.10.1.ebuild
new file mode 100644
index 000000000000..53e9c89a74c7
--- /dev/null
+++ b/www-apps/dspam-web/dspam-web-3.10.1.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+inherit webapp
+
+DESCRIPTION="Web based administration and user controls for dspam"
+HOMEPAGE="http://dspam.nuclearelephant.com/"
+SRC_URI="http://dspam.nuclearelephant.com/sources/dspam-${PV}.tar.gz"
+
+LICENSE="AGPL-3"
+KEYWORDS="amd64 ~ppc x86"
+IUSE=""
+
+RDEPEND=">=mail-filter/dspam-${PV}[-user-homedirs]
+ dev-perl/GD[png]
+ dev-perl/GD-Graph3d
+ dev-perl/GDGraph
+ dev-perl/GDTextUtil"
+
+need_httpd_cgi
+
+# some FHS-like structure
+HOMEDIR="/var/spool/dspam"
+CONFDIR="/etc/mail/dspam"
+
+S="${WORKDIR}/dspam-${PV}"
+
+src_configure() {
+ econf \
+ --with-dspam-home=${HOMEDIR} \
+ --sysconfdir=${CONFDIR}
+}
+
+src_compile() {
+ cd webui
+ default
+}
+
+src_install() {
+ webapp_src_preinst
+
+ cd webui
+ insinto "${MY_HTDOCSDIR}"
+ insopts -m644
+ doins htdocs/*.{css,gif}
+ insinto "${MY_CGIBINDIR}/templates"
+ doins cgi-bin/templates/*.html
+ insinto "${MY_CGIBINDIR}"
+ doins cgi-bin/{admins,configure.pl,default.prefs,rgb.txt,*.cgi}
+
+ webapp_configfile "${MY_CGIBINDIR}"/{admins,configure.pl,default.prefs,rgb.txt}
+
+ webapp_hook_script "${FILESDIR}/setperms"
+ webapp_postinst_txt en "${FILESDIR}/postinst-en.txt"
+
+ webapp_src_install
+}
+
+pkg_postinst() {
+ ewarn "If you're using apache dspam-web's config requires the scripts in the cgi-bin"
+ ewarn "to be run as dspam:dspam. You will have to put a global SuexecUserGroup"
+ ewarn "declaration in the main server config which will force everything in cgi-bin"
+ ewarn "to run as dspam:dspam."
+ ewarn "You should use a dedicated virtual host for this application or at least"
+ ewarn "one that don't have any other cgi scripts."
+ ewarn
+ webapp_pkg_postinst
+}