summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /www-apps/bitten
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'www-apps/bitten')
-rw-r--r--www-apps/bitten/Manifest1
-rw-r--r--www-apps/bitten/bitten-0.6-r1.ebuild50
-rw-r--r--www-apps/bitten/files/bitten.confd19
-rw-r--r--www-apps/bitten/files/bitten.initd20
-rw-r--r--www-apps/bitten/metadata.xml8
5 files changed, 98 insertions, 0 deletions
diff --git a/www-apps/bitten/Manifest b/www-apps/bitten/Manifest
new file mode 100644
index 000000000000..a74d82d0b43d
--- /dev/null
+++ b/www-apps/bitten/Manifest
@@ -0,0 +1 @@
+DIST Bitten-0.6.tar.gz 340031 SHA256 0ccbe1c6c798d980d2b9024a86cd04710b58c9a129f02b82bf72d96efd6e7026 SHA512 d0881be4d36dfa939f5b48163e37583b522a18b3bb736b435d6fa7d7e1eb8fa98e2b7c7651a5e16380597555ce1ffd6d35dc37a74dd69a0ed4b64e36ec9ecfb0 WHIRLPOOL aa036add696966c0db8a322a6f21f0784bab6eb0e2aab323ebeb60c349102c82613860ccfc28690d56cba6f57906854d3ca2cfd5078636ad4f1e324b228109dd
diff --git a/www-apps/bitten/bitten-0.6-r1.ebuild b/www-apps/bitten/bitten-0.6-r1.ebuild
new file mode 100644
index 000000000000..86c4c6648f2a
--- /dev/null
+++ b/www-apps/bitten/bitten-0.6-r1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+MY_PN=Bitten
+MY_P=${MY_PN}-${PV}
+
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.* 2.7-pypy-*"
+DISTUTILS_SRC_TEST="setup.py"
+
+inherit distutils user
+
+DESCRIPTION="Continuous integration plugin for Trac"
+HOMEPAGE="http://bitten.edgewall.org/"
+SRC_URI="http://ftp.edgewall.com/pub/${PN}/${MY_P}.tar.gz"
+
+LICENSE="BSD Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="server test"
+
+CDEPEND="dev-python/setuptools"
+DEPEND="${CDEPEND}
+ test? ( dev-python/figleaf )"
+RDEPEND="${CDEPEND}
+ server? ( www-apps/trac )"
+
+S=${WORKDIR}/${MY_P}
+
+pkg_setup() {
+ python_pkg_setup
+ DISTUTILS_GLOBAL_OPTIONS=("2.* $(use_with server master)")
+ enewgroup tracd
+ enewuser ${PN} -1 -1 /var/tmp/${PN} tracd
+}
+
+src_install() {
+ distutils_src_install
+ newinitd "${FILESDIR}"/${PN}.initd ${PN}
+ newconfd "${FILESDIR}"/${PN}.confd ${PN}
+}
+
+pkg_postinst() {
+ touch "${ROOT}"/var/log/${PN}.log
+ chown -f ${PN}:tracd "${ROOT}"/var/log/${PN}.log
+}
diff --git a/www-apps/bitten/files/bitten.confd b/www-apps/bitten/files/bitten.confd
new file mode 100644
index 000000000000..49af46916070
--- /dev/null
+++ b/www-apps/bitten/files/bitten.confd
@@ -0,0 +1,19 @@
+# The commented variables in this file are the defaults that are used
+# in the init-script. You don't need to uncomment them except to
+# customize them to different values.
+
+# Server running bitten
+#BITTEN_SERVER="http://localhost/trac/builds"
+
+# Temporary dir wher builds take place
+#BITTEN_TMPDIR="/var/tmp/bitten"
+
+# Log file
+#BITTEN_LOG="/var/log/bitten.log"
+
+# Additional options for bitten
+#BITTEN_OPTS=""
+
+# User and group as which to run bitten
+#BITTEN_USER="bitten"
+#BITTEN_GROUP="tracd"
diff --git a/www-apps/bitten/files/bitten.initd b/www-apps/bitten/files/bitten.initd
new file mode 100644
index 000000000000..99301d0188b0
--- /dev/null
+++ b/www-apps/bitten/files/bitten.initd
@@ -0,0 +1,20 @@
+#!/sbin/runscript
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Id$
+
+start() {
+ ebegin "Starting Bitten slave"
+ start-stop-daemon --start --user ${BITTEN_USER:-bitten} --group ${BITTEN_GROUP:-tracd} \
+ --pidfile /var/run/bitten.pid --make-pidfile --background \
+ --exec /usr/bin/bitten-slave -- \
+ ${BITTEN_SERVER} -d ${BITTEN_TMPDIR:-/var/tmp/bitten} -l ${BITTEN_LOG:-/var/log/bitten.log} \
+ ${BITTEN_OPTS}
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping Bitten slave"
+ start-stop-daemon --stop --quiet --pidfile /var/run/bitten.pid
+ eend $?
+}
diff --git a/www-apps/bitten/metadata.xml b/www-apps/bitten/metadata.xml
new file mode 100644
index 000000000000..10dc24f7fcbb
--- /dev/null
+++ b/www-apps/bitten/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <use>
+ <flag name='server'>Install master instance that integrates itself with Trac</flag>
+ </use>
+</pkgmetadata>