summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@integralblue.com>2017-08-04 09:26:03 -0400
committerDavid Seifert <soap@gentoo.org>2017-08-07 19:12:11 +0200
commit4edd88f5877644b95f538aa1be9a0c74019f0518 (patch)
tree9dad653726fdb10d01a4c26d4a0e025a297ae5fd /www-apache/mod_h2/mod_h2-9999.ebuild
parentprofiles: Drop mask as it was set for pacman-4.x in unmaintained state. (diff)
downloadgentoo-4edd88f5877644b95f538aa1be9a0c74019f0518.tar.gz
gentoo-4edd88f5877644b95f538aa1be9a0c74019f0518.tar.bz2
gentoo-4edd88f5877644b95f538aa1be9a0c74019f0518.zip
www-apache/mod_h2: version 1.10.10, use EAPI=6
Package-Manager: Portage-2.3.6, Repoman-2.3.3 Closes: https://github.com/gentoo/gentoo/pull/5296
Diffstat (limited to 'www-apache/mod_h2/mod_h2-9999.ebuild')
-rw-r--r--www-apache/mod_h2/mod_h2-9999.ebuild16
1 files changed, 7 insertions, 9 deletions
diff --git a/www-apache/mod_h2/mod_h2-9999.ebuild b/www-apache/mod_h2/mod_h2-9999.ebuild
index 48f0e8ef3707..eaf87ecaf6b9 100644
--- a/www-apache/mod_h2/mod_h2-9999.ebuild
+++ b/www-apache/mod_h2/mod_h2-9999.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI="5"
+EAPI="6"
inherit apache-module
@@ -9,8 +9,9 @@ MY_P="${PN/h2/http2}-${PV}"
if [[ ${PV} == 9999 ]] ; then
EGIT_REPO_URI="https://github.com/icing/mod_h2.git"
- inherit git-2
+ inherit autotools git-r3
else
+ S="${WORKDIR}/${MY_P}"
SRC_URI="https://github.com/icing/mod_h2/releases/download/v${PV}/${MY_P}.tar.gz"
KEYWORDS="~amd64 ~x86"
fi
@@ -26,14 +27,11 @@ RDEPEND=">=net-libs/nghttp2-1.0
>=www-servers/apache-2.4.20[-apache2_modules_http2,ssl?]"
DEPEND="${RDEPEND}"
-S="${WORKDIR}/${MY_P}"
-
need_apache2_4
-src_configure() {
- econf \
- --docdir='$(datarootdir)'/doc/${PF} \
- --disable-werror
+src_prepare() {
+ default
+ [[ ${PV} = 9999 ]] && eautoreconf
}
src_compile() {