summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@gentoo.org>2021-07-06 10:00:39 -0400
committerCraig Andrews <candrews@gentoo.org>2021-07-06 10:01:23 -0400
commitb2d08cc060960ec8f1cad8fa4166000f45fb354b (patch)
treebc2901ff20a911924c3ef5ed4bc7607044558061 /www-apache/mod_h2/mod_h2-1.15.21.ebuild
parentsys-devel/clang-runtime: Remove 12.0.1-rc1 & -rc2 (diff)
downloadgentoo-b2d08cc060960ec8f1cad8fa4166000f45fb354b.tar.gz
gentoo-b2d08cc060960ec8f1cad8fa4166000f45fb354b.tar.bz2
gentoo-b2d08cc060960ec8f1cad8fa4166000f45fb354b.zip
www-apache/mod_h2: 1.15.21 version bump
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Craig Andrews <candrews@gentoo.org>
Diffstat (limited to 'www-apache/mod_h2/mod_h2-1.15.21.ebuild')
-rw-r--r--www-apache/mod_h2/mod_h2-1.15.21.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/www-apache/mod_h2/mod_h2-1.15.21.ebuild b/www-apache/mod_h2/mod_h2-1.15.21.ebuild
new file mode 100644
index 000000000000..9d7e1b600b10
--- /dev/null
+++ b/www-apache/mod_h2/mod_h2-1.15.21.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit apache-module autotools
+
+MY_P="${PN/h2/http2}-${PV}"
+
+if [[ ${PV} == 9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/icing/mod_h2.git"
+ inherit git-r3
+else
+ S="${WORKDIR}/${MY_P}"
+ SRC_URI="https://github.com/icing/mod_h2/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="HTTP/2 module for Apache"
+HOMEPAGE="https://github.com/icing/mod_h2"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="ssl"
+
+RDEPEND=">=net-libs/nghttp2-1.0
+ >=www-servers/apache-2.4.48[-apache2_modules_http2,ssl?]"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${P}"
+
+need_apache2_4
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_compile() {
+ default
+}
+
+src_install() {
+ default
+
+ APACHE2_MOD_DEFINE="HTTP2"
+ insinto "${APACHE_MODULES_CONFDIR}"
+ newins "${FILESDIR}/mod_http2.conf" "41_mod_http2.conf"
+}