summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2022-08-28 12:50:52 -0400
committerIonen Wolkens <ionen@gentoo.org>2022-09-03 15:46:00 -0400
commit51c8f37560dc84a1cd059dc6d7540678c87cce9b (patch)
treebfdd4609ca294b78d9a9d015d706004a9269e9a7 /virtual/wine
parentapp-emulation/wine-proton: new package, add 7.0.4 (diff)
downloadgentoo-51c8f37560dc84a1cd059dc6d7540678c87cce9b.tar.gz
gentoo-51c8f37560dc84a1cd059dc6d7540678c87cce9b.tar.bz2
gentoo-51c8f37560dc84a1cd059dc6d7540678c87cce9b.zip
virtual/wine: EAPI7->8, add app-emulation/wine-proton
Also cleanup extra || ( ), no-op and I don't believe these will have uses now that wine-any is gone. Related to this, not convinced USE on this virtual are still meaningful but don't want to change things around at the moment, so setting wine-proton same way as staging. Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'virtual/wine')
-rw-r--r--virtual/wine/metadata.xml1
-rw-r--r--virtual/wine/wine-0-r8.ebuild25
2 files changed, 26 insertions, 0 deletions
diff --git a/virtual/wine/metadata.xml b/virtual/wine/metadata.xml
index a7c476ea196a..a5e53660da5c 100644
--- a/virtual/wine/metadata.xml
+++ b/virtual/wine/metadata.xml
@@ -6,6 +6,7 @@
<name>Wine</name>
</maintainer>
<use>
+ <flag name="proton">Enable Valve Software's fork of Wine</flag>
<flag name="staging">Enable Wine-Staging's Patchset</flag>
</use>
<stabilize-allarches/>
diff --git a/virtual/wine/wine-0-r8.ebuild b/virtual/wine/wine-0-r8.ebuild
new file mode 100644
index 000000000000..af40db7eedf9
--- /dev/null
+++ b/virtual/wine/wine-0-r8.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Virtual for Wine that supports multiple variants and slotting"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+abi_x86_32 +abi_x86_64 proton staging"
+REQUIRED_USE="|| ( abi_x86_32 abi_x86_64 )"
+
+# Note, the ordering here is intentional, to take advantage of the short-circuit
+# logic of portage, to enforce wine-vanilla as default for new users. The idea
+# behind this is that some USE flags may pull in 3rd-party patchsets, so default
+# of vanilla prevents that.
+RDEPEND="
+ proton? ( app-emulation/wine-proton )
+ staging? ( app-emulation/wine-staging[staging] )
+ || (
+ app-emulation/wine-vanilla[abi_x86_32=,abi_x86_64=]
+ app-emulation/wine-proton[abi_x86_32=,abi_x86_64=]
+ app-emulation/wine-staging[abi_x86_32=,abi_x86_64=]
+ )
+ !app-emulation/wine:0"