summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2017-04-14 09:35:57 +0200
committerFabian Groffen <grobian@gentoo.org>2017-04-14 09:35:57 +0200
commit898508cae55771dd611ff9e883611a905c27f301 (patch)
treec39a850d96d725d5b79afcdad540fef0263a3c5c /sys-process
parentpkill-darwin: bump from EAPI=3 to EAPI=6 (diff)
downloadgentoo-898508cae55771dd611ff9e883611a905c27f301.tar.gz
gentoo-898508cae55771dd611ff9e883611a905c27f301.tar.bz2
gentoo-898508cae55771dd611ff9e883611a905c27f301.zip
sys-process/unixtop: bump from EAPI=0 to EAPI=6
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'sys-process')
-rw-r--r--sys-process/unixtop/unixtop-3.8_beta1-r3.ebuild19
1 files changed, 7 insertions, 12 deletions
diff --git a/sys-process/unixtop/unixtop-3.8_beta1-r3.ebuild b/sys-process/unixtop/unixtop-3.8_beta1-r3.ebuild
index 38bfa90fe465..d32e3863a6f7 100644
--- a/sys-process/unixtop/unixtop-3.8_beta1-r3.ebuild
+++ b/sys-process/unixtop/unixtop-3.8_beta1-r3.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
+EAPI=6
+
inherit eutils autotools
DESCRIPTION="top for UNIX systems"
@@ -17,19 +19,18 @@ DEPEND="${RDEPEND}"
S=${WORKDIR}/top-${PV/_/}
-src_unpack() {
- unpack ${A}
- cd "${S}"
+src_prepare() {
epatch "${FILESDIR}"/${P}-ncurses.patch
epatch "${FILESDIR}"/${P}-no-AX-macros.patch
epatch "${FILESDIR}"/${P}-renice-segfault.patch
epatch "${FILESDIR}"/${P}-memleak-fix-v2.patch
epatch "${FILESDIR}"/${P}-high-threadid-crash.patch
epatch "${FILESDIR}"/${P}-percent-cpu.patch
+ eapply_user
eautoreconf
}
-src_compile() {
+src_configure() {
local myconf=
# don't do bi-arch cruft on hosts that support that, such as Solaris
@@ -38,11 +39,5 @@ src_compile() {
# configure demands an override because on OSX this is "experimental"
[[ ${CHOST} == *-darwin* ]] && myconf="${myconf} --with-module=macosx"
- econf ${myconf} || die
- emake || die
-}
-
-src_install() {
- emake DESTDIR="${D}" install
- dodoc README FAQ Y2K
+ econf ${myconf}
}