summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <patrick.mclean@sony.com>2021-01-28 19:10:25 -0800
committerPatrick McLean <chutzpah@gentoo.org>2021-01-28 19:10:25 -0800
commit4e681e56df20722f7f313d51168a8bacf13909cc (patch)
treeeae9fbb7e6e0cadb024d41520463674c5d0aed8e /sys-process
parentsys-libs/compiler-rt: Strip the prefix patch for 12+ (diff)
downloadgentoo-4e681e56df20722f7f313d51168a8bacf13909cc.tar.gz
gentoo-4e681e56df20722f7f313d51168a8bacf13909cc.tar.bz2
gentoo-4e681e56df20722f7f313d51168a8bacf13909cc.zip
sys-process/bpytop-1.0.61: Fix patch
Copyright: Sony Interactive Entertainment Inc. Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'sys-process')
-rw-r--r--sys-process/bpytop/bpytop-1.0.61.ebuild10
-rw-r--r--sys-process/bpytop/files/bpytop-1.0.61-tests.patch20
2 files changed, 22 insertions, 8 deletions
diff --git a/sys-process/bpytop/bpytop-1.0.61.ebuild b/sys-process/bpytop/bpytop-1.0.61.ebuild
index 3d2f869c509f..0dd9a9cadf0b 100644
--- a/sys-process/bpytop/bpytop-1.0.61.ebuild
+++ b/sys-process/bpytop/bpytop-1.0.61.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python3_{6..9} pypy3 )
+PYTHON_COMPAT=( python3_{6..9} )
DISTUTILS_USE_SETUPTOOLS=pyproject.toml
inherit distutils-r1
@@ -23,11 +23,5 @@ RDEPEND="
distutils_enable_tests pytest
PATCHES=(
- "${FILESDIR}/bpytop-1.0.51-tests.patch"
+ "${FILESDIR}/bpytop-1.0.61-tests.patch"
)
-
-src_install() {
- insinto "/usr/share/${PN}/themes"
- doins bpytop-themes/*.theme
- distutils-r1_src_install
-}
diff --git a/sys-process/bpytop/files/bpytop-1.0.61-tests.patch b/sys-process/bpytop/files/bpytop-1.0.61-tests.patch
new file mode 100644
index 000000000000..51cef1ce6394
--- /dev/null
+++ b/sys-process/bpytop/files/bpytop-1.0.61-tests.patch
@@ -0,0 +1,20 @@
+diff --git a/bpytop.py b/bpytop.py
+index 38d6e8b..12e4853 100755
+--- a/bpytop.py
++++ b/bpytop.py
+@@ -65,10 +65,11 @@ args.add_argument("-v", "--version", action="store_true", help = "show versio
+ args.add_argument("--debug", action="store_true", help = "start with loglevel set to DEBUG overriding value set in config")
+ stdargs = args.parse_args()
+
+-if stdargs.version:
+- print(f'bpytop version: {VERSION}\n'
+- f'psutil version: {".".join(str(x) for x in psutil.version_info)}')
+- raise SystemExit(0)
++if __name__ == "__main__":
++ if stdargs.version:
++ print(f'bpytop version: {VERSION}\n'
++ f'psutil version: {".".join(str(x) for x in psutil.version_info)}')
++ raise SystemExit(0)
+
+ ARG_BOXES: str = stdargs.boxes
+ LOW_COLOR: bool = stdargs.low_color