summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-02-21 07:52:25 +0000
committerSam James <sam@gentoo.org>2024-02-21 07:53:02 +0000
commit2478fa3fb9482b84cd1ab953479916bd60ab204e (patch)
treed4e1b370d411b0717675641dd634745554e63158 /sys-process
parentsys-process/numactl: drop 2.0.14, 2.0.14-r1, 2.0.16 (diff)
downloadgentoo-2478fa3fb9482b84cd1ab953479916bd60ab204e.tar.gz
gentoo-2478fa3fb9482b84cd1ab953479916bd60ab204e.tar.bz2
gentoo-2478fa3fb9482b84cd1ab953479916bd60ab204e.zip
sys-process/numactl: add 2.0.18
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-process')
-rw-r--r--sys-process/numactl/Manifest1
-rw-r--r--sys-process/numactl/files/numactl-2.0.18-numademo-cflags.patch15
-rw-r--r--sys-process/numactl/numactl-2.0.18.ebuild67
-rw-r--r--sys-process/numactl/numactl-9999.ebuild4
4 files changed, 85 insertions, 2 deletions
diff --git a/sys-process/numactl/Manifest b/sys-process/numactl/Manifest
index 1c6384c9de51..dd43d2b7a2b7 100644
--- a/sys-process/numactl/Manifest
+++ b/sys-process/numactl/Manifest
@@ -1 +1,2 @@
DIST numactl-2.0.16.tar.gz 450003 BLAKE2B 3ac38129b914d62958182020f57969878f2817bd3155c6b5362a66f96deb2058268fa8004729a2d3333642c8c0bee73a451030a287958fa145247b7685e426aa SHA512 6e17724567c363a08994fe7f5569b6ec62bd1ae608244945fddcb2d6a212b08140340f0d862595ba4016fcba95193e851cb286798f685d314b4c72687af6d879
+DIST numactl-2.0.18.tar.gz 447393 BLAKE2B c89d0492e7b3a3e7c569c0081ecf914f2a145d28de1fa0edf26ab23c5e9e1605e4e8f127fd28498436dd2c36ebf9a59e1feba2b525b2b3a00e2aab7be5eb0a54 SHA512 17abe7a3744065edb5ec1e27135873629031c509313809ca99e0d9254f7a5cb00cce5b32173e811e9b9d7cb407aabdcbe3c6be6e3b094ad3e7d696a154b7f1ec
diff --git a/sys-process/numactl/files/numactl-2.0.18-numademo-cflags.patch b/sys-process/numactl/files/numactl-2.0.18-numademo-cflags.patch
new file mode 100644
index 000000000000..629d625915f0
--- /dev/null
+++ b/sys-process/numactl/files/numactl-2.0.18-numademo-cflags.patch
@@ -0,0 +1,15 @@
+https://bugs.gentoo.org/540856
+
+respect user CFLAGS
+
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -25,7 +25,7 @@ numastat_CFLAGS = $(AM_CFLAGS) -std=gnu99 -DVERSION=\"$(shell cat ${srcdir}/VERS
+
+ numademo_SOURCES = numademo.c stream_lib.c stream_lib.h mt.c mt.h clearcache.c util.c clearcache.h
+ numademo_CPPFLAGS = $(AM_CPPFLAGS) -DHAVE_STREAM_LIB -DHAVE_MT -DHAVE_CLEAR_CACHE
+-numademo_CFLAGS = $(AM_CFLAGS) -O3 -ffast-math -funroll-loops
++numademo_CFLAGS = $(AM_CFLAGS) -ffast-math -funroll-loops
+ if HAVE_TREE_VECTORIZE
+ numademo_CFLAGS += -ftree-vectorize
+ endif
diff --git a/sys-process/numactl/numactl-2.0.18.ebuild b/sys-process/numactl/numactl-2.0.18.ebuild
new file mode 100644
index 000000000000..4b812dd7dfed
--- /dev/null
+++ b/sys-process/numactl/numactl-2.0.18.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools multilib-minimal
+
+DESCRIPTION="Utilities and libraries for NUMA systems"
+HOMEPAGE="https://github.com/numactl/numactl"
+if [[ ${PV} == 9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/numactl/numactl.git"
+else
+ SRC_URI="https://github.com/numactl/numactl/releases/download/v${PV}/${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm64 ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="static-libs"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.0.18-numademo-cflags.patch # bug #540856
+)
+
+src_prepare() {
+ default
+
+ eautoreconf
+
+ # We need to copy the sources or else tests will fail
+ multilib_copy_sources
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE="${S}" econf $(use_enable static-libs static)
+}
+
+multilib_src_compile() {
+ multilib_is_native_abi && default || emake libnuma.la
+}
+
+multilib_src_test() {
+ if multilib_is_native_abi ; then
+ if [[ -d /sys/devices/system/node ]] ; then
+ einfo "The only generically safe test is regress2."
+ einfo "The other test cases require 2 NUMA nodes."
+ emake regress2
+ else
+ ewarn "You do not have baseline NUMA support in your kernel, skipping tests."
+ fi
+ fi
+}
+
+multilib_src_install() {
+ emake DESTDIR="${D}" \
+ install$(multilib_is_native_abi || echo "-libLTLIBRARIES install-includeHEADERS")
+ find "${ED}"/usr/ -type f -name libnuma.la -delete || die
+}
+
+multilib_src_install_all() {
+ local DOCS=( README.md )
+ einstalldocs
+
+ # Delete man pages provided by the man-pages package, bug #238805
+ rm -r "${ED}"/usr/share/man/man[25] || die
+}
diff --git a/sys-process/numactl/numactl-9999.ebuild b/sys-process/numactl/numactl-9999.ebuild
index 75c8f3695219..4b812dd7dfed 100644
--- a/sys-process/numactl/numactl-9999.ebuild
+++ b/sys-process/numactl/numactl-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -20,7 +20,7 @@ SLOT="0"
IUSE="static-libs"
PATCHES=(
- "${FILESDIR}"/${PN}-2.0.14-numademo-cflags.patch # bug #540856
+ "${FILESDIR}"/${PN}-2.0.18-numademo-cflags.patch # bug #540856
)
src_prepare() {