summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2016-06-19 00:26:07 -0400
committerTim Harder <radhermit@gentoo.org>2016-06-19 00:26:07 -0400
commit1f65aba00da5718fb249c97ed2d0022148479efe (patch)
treebce6e047339becf617fc594a918040de0620027d /sys-process
parentdev-lang/swig: remove old (diff)
downloadgentoo-1f65aba00da5718fb249c97ed2d0022148479efe.tar.gz
gentoo-1f65aba00da5718fb249c97ed2d0022148479efe.tar.bz2
gentoo-1f65aba00da5718fb249c97ed2d0022148479efe.zip
sys-process/procenv: version bump to 0.46
Diffstat (limited to 'sys-process')
-rw-r--r--sys-process/procenv/Manifest1
-rw-r--r--sys-process/procenv/procenv-0.46.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/sys-process/procenv/Manifest b/sys-process/procenv/Manifest
index 047785ac3aa5..55865ab4c3b6 100644
--- a/sys-process/procenv/Manifest
+++ b/sys-process/procenv/Manifest
@@ -1,2 +1,3 @@
DIST procenv-0.39.tar.gz 270745 SHA256 1ea203b28290dbabc6bd221b857b439ad4f68f38fac560d4966ff6e6a4d71922 SHA512 b34accc92445aeb9ccb1f45dc3cca2fcf25e2e9ab31e2126f086c884e2562093e292d242ba7ef3aa03e342ad8398b01c08fda133a2d8f0a87693be8cb96c621b WHIRLPOOL 2766cb8239f58bff2ee0bc66e4848f17f52b9151fc94044aeff9c766da968c7159f101b0b092121cb70165fac370b7dd237abcc09d8789db5bdcea5468e513bd
DIST procenv-0.45.tar.gz 241046 SHA256 5fc3d650783f57fa8ba90c5e0cf0fc28f5e0bf22af38f2dbb9e8574d4e13fad3 SHA512 b9d5a9cda7ff2cc406555a2a82664e45172250af5943c882084fe0d6d067cc19cbc74b6cb9203d3be64a33797ad3c3afa8ad9d5414546ee8e047947790956ff1 WHIRLPOOL 786a80ca01569dca399436e47c335f65893cd4414eb5ef770b3100a2de5328f82792508137a3274c31932db4e81eabd1d8fd1cbcf13efe4acebfdeb9ce4359a8
+DIST procenv-0.46.tar.gz 243301 SHA256 5c8253e63c1f90e80bfdd2076b5cdf916513667453e165e0660afb68f60fb98b SHA512 3f6ff6ce0c4218f9eba6d8172fcd60e380eb1d555114c871be5e4f5815cc7dfcba5f3b2ddf731da0d250f1e8f9754d70805a479c3bf283c5e48e77b8cb91d7a1 WHIRLPOOL ebddbe398bf8bdebae87bfc59cdc2e0fe57f804c7e34c7f18978c8bcbcbeb84ee7f406e8b7788f6ead64b292d244421b1cb48aa2fde49be9792ceaeb8885b63c
diff --git a/sys-process/procenv/procenv-0.46.ebuild b/sys-process/procenv/procenv-0.46.ebuild
new file mode 100644
index 000000000000..fea114e4335f
--- /dev/null
+++ b/sys-process/procenv/procenv-0.46.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit autotools
+
+DESCRIPTION="command-line utility to show process environment"
+HOMEPAGE="https://github.com/jamesodhunt/procenv"
+SRC_URI="https://github.com/jamesodhunt/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc64 ~x86"
+IUSE="test"
+
+DEPEND="
+ virtual/pkgconfig
+ test? ( dev-libs/check )
+"
+
+src_prepare() {
+ local PATCHES=(
+ "${FILESDIR}"/${PN}-0.45-sysmacros.patch
+ "${FILESDIR}"/${PN}-0.45-flags.patch
+ )
+
+ default
+ eautoreconf
+}