summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-01-17 21:36:55 +0000
committerSam James <sam@gentoo.org>2023-01-17 21:37:28 +0000
commitf0b0bf2d03b9dded103bec8ae1b35a52b5a8cffc (patch)
tree993f50c61bef0e5b3602a0045852af86b386dbbb /sys-process/lsof
parentdev-tcltk/tktable: incompatible function pointer types (diff)
downloadgentoo-f0b0bf2d03b9dded103bec8ae1b35a52b5a8cffc.tar.gz
gentoo-f0b0bf2d03b9dded103bec8ae1b35a52b5a8cffc.tar.bz2
gentoo-f0b0bf2d03b9dded103bec8ae1b35a52b5a8cffc.zip
sys-process/lsof: add 4.97.0
Drop keywords for big port to autotools. Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-process/lsof')
-rw-r--r--sys-process/lsof/Manifest1
-rw-r--r--sys-process/lsof/lsof-4.97.0.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/sys-process/lsof/Manifest b/sys-process/lsof/Manifest
index f2a14ca41f5b..fc6fbefc777d 100644
--- a/sys-process/lsof/Manifest
+++ b/sys-process/lsof/Manifest
@@ -1,2 +1,3 @@
DIST lsof-4.96.3.tar.gz 1342843 BLAKE2B 79e276d0db5138c356cc8bfa32e6f991ce8860644eb5d02f49ba04ce08076232f0fb8b10e143ee135205de5c64bd053d7bf021e48d666b65ffc01c0a47b76116 SHA512 ad17a73590ffb154a13b8b5de8ada738ce343fcc833012b2a5e9b3bda587785b09ae8bf090a99fba8e84b788c2a6d61eaa7359f939bfa68d2423e604801e2a98
DIST lsof-4.96.4.tar.gz 1342514 BLAKE2B c420e2f928ffa8148a62298ba7176f860b15f9e78f4c2dc299162614a1d9b94a85c42ee93ef5e92b8a99f1c67e496cf2c848874b844c22c287aab53bfe211c58 SHA512 06f8005e1eb72324c1fd603d8b8287a61ad6fdec182e9da833991a8915aaa69c416af1564d3b1087cb08b3504ef9b15cdffec7051605e89d945d6750ec8da985
+DIST lsof-4.97.0.tar.gz 1130140 BLAKE2B 0034550ebbd41da66d7fef8d8f8ae148faa1f59ec086d2803ba406aeeff15f461c2dd8d9309724b61647164a66588f31027b972fd14c54a7f10432b0f0bbb46f SHA512 7ac81c26374305d8fd3b114fb697f093f289367a3f2577d9bc3f671fef1ee477c97ec670382fb0e7fee4ac4eb75120ef3b0d9356d5c4c39f4c00af324e436287
diff --git a/sys-process/lsof/lsof-4.97.0.ebuild b/sys-process/lsof/lsof-4.97.0.ebuild
new file mode 100644
index 000000000000..ad7040fcc803
--- /dev/null
+++ b/sys-process/lsof/lsof-4.97.0.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools flag-o-matic
+
+MY_P="${P/-/_}"
+DESCRIPTION="Lists open files for running Unix processes"
+HOMEPAGE="https://github.com/lsof-org/lsof"
+SRC_URI="https://github.com/lsof-org/lsof/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="lsof"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="rpc selinux"
+
+RDEPEND="
+ rpc? ( net-libs/libtirpc )
+ selinux? ( sys-libs/libselinux )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ sys-apps/groff
+ rpc? ( virtual/pkgconfig )
+"
+
+# Needs fixing first
+RESTRICT="test"
+
+src_prepare() {
+ default
+
+ eautoreconf
+}
+
+src_configure() {
+ export ac_cv_header_rpc_rpc_h=$(usex rpc)
+ export ac_cv_header_selinux_selinux_h=$(usex selinux)
+
+ [[ ${CHOST} == *-solaris2.11 ]] && append-cppflags -DHAS_PAD_MUTEX
+
+ econf
+}
+
+src_compile() {
+ emake DEBUG="" all
+}
+
+pkg_postinst() {
+ if [[ ${CHOST} == *-solaris* ]] ; then
+ einfo "Note: to use lsof on Solaris you need read permissions on"
+ einfo "/dev/kmem, i.e. you need to be root, or to be in the group sys"
+ elif [[ ${CHOST} == *-aix* ]] ; then
+ einfo "Note: to use lsof on AIX you need read permissions on /dev/mem and"
+ einfo "/dev/kmem, i.e. you need to be root, or to be in the group system"
+ fi
+}