summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-12-28 04:18:47 +0000
committerSam James <sam@gentoo.org>2023-12-28 04:18:47 +0000
commit3d67b1f7855e0235bad9f1eb0d454992841b3912 (patch)
treedcfb06158ed3d231196d6817552264a3c7ae0462 /sys-process/cronie
parentsys-apps/pciutils: drop 3.8.0-r1, 3.9.0 (diff)
downloadgentoo-3d67b1f7855e0235bad9f1eb0d454992841b3912.tar.gz
gentoo-3d67b1f7855e0235bad9f1eb0d454992841b3912.tar.bz2
gentoo-3d67b1f7855e0235bad9f1eb0d454992841b3912.zip
sys-process/cronie: drop 1.6.1-r3
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-process/cronie')
-rw-r--r--sys-process/cronie/Manifest1
-rw-r--r--sys-process/cronie/cronie-1.6.1-r3.ebuild118
-rw-r--r--sys-process/cronie/files/cronie-1.5.3-systemd.patch33
3 files changed, 0 insertions, 152 deletions
diff --git a/sys-process/cronie/Manifest b/sys-process/cronie/Manifest
index 280c35491b30..a302c696b61e 100644
--- a/sys-process/cronie/Manifest
+++ b/sys-process/cronie/Manifest
@@ -1,2 +1 @@
-DIST cronie-1.6.1.tar.gz 149913 BLAKE2B 7b563b90f386a8df09398661e2b3ddc1f83d6c0d19290a02c0622be461e1d160218572adf132d634c60ef8fd0a4bb100e830b90e26270c28c75a69591ccc18a6 SHA512 1e095df9670ec25d6629f4cf2cacd82c6c1cb1487a859815a7881a1d130e4f18f9976396f773abae24dadc232166bb6467bbaeac1cb0254209fcadf3530d5e6f
DIST cronie-1.7.0.tar.gz 271404 BLAKE2B 44745f68dba212da60f3013b10737be2390d8c76186dc641fa1930b1c7d103fa2e3127a63fe73571434683137044f7fda8cc31435c59092a14c0091a372ffead SHA512 a8e6688a164540e2cd3741c58813b6684c4c22a04806bcc8ba028a9ff72f986f165715ac3663bd34133af6566bdbd272a3e7be893f139e315aef35b2dbeb622f
diff --git a/sys-process/cronie/cronie-1.6.1-r3.ebuild b/sys-process/cronie/cronie-1.6.1-r3.ebuild
deleted file mode 100644
index 2658c34efbc0..000000000000
--- a/sys-process/cronie/cronie-1.6.1-r3.ebuild
+++ /dev/null
@@ -1,118 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit autotools cron flag-o-matic pam systemd
-
-DESCRIPTION="Cronie is a standard UNIX daemon cron based on the original vixie-cron"
-HOMEPAGE="https://github.com/cronie-crond/cronie"
-SRC_URI="https://github.com/cronie-crond/cronie/archive/${P}.tar.gz"
-S="${WORKDIR}/${PN}-${P}"
-
-LICENSE="ISC BSD BSD-2 GPL-2"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86"
-IUSE="+anacron +inotify pam selinux"
-
-DEPEND="
- pam? ( sys-libs/pam )
- anacron? (
- !sys-process/anacron
- !sys-process/systemd-cron
- elibc_musl? ( sys-libs/obstack-standalone )
- )
- selinux? ( sys-libs/libselinux )
-"
-BDEPEND="acct-group/crontab"
-RDEPEND="
- ${BDEPEND}
- ${DEPEND}
- sys-apps/debianutils
-"
-
-#cronie supports /etc/crontab
-CRON_SYSTEM_CRONTAB="yes"
-
-PATCHES=(
- "${FILESDIR}/${PN}-1.5.3-systemd.patch"
-)
-
-src_prepare() {
- default
- eautoreconf
-}
-
-src_configure() {
- local myeconfargs=(
- $(use_with inotify)
- $(use_with pam)
- $(use_with selinux)
- $(use_enable anacron)
- --enable-syscrontab
- # Required for correct pidfile location #835814
- --runstatedir="${EPREFIX}/run"
- --with-daemon_username=cron
- --with-daemon_groupname=cron
- )
-
- if use anacron ; then
- if use elibc_musl ; then
- append-cflags "-lobstack"
- fi
- fi
- SPOOL_DIR="/var/spool/cron/crontabs" \
- ANACRON_SPOOL_DIR="/var/spool/anacron" \
- econf "${myeconfargs[@]}"
-}
-
-src_install() {
- default
-
- docrondir -m 1730 -o root -g crontab
- fowners root:crontab /usr/bin/crontab
- fperms 2751 /usr/bin/crontab
-
- newconfd "${S}"/crond.sysconfig ${PN}
-
- insinto /etc
- newins "${FILESDIR}/${PN}-crontab" crontab
- newins "${FILESDIR}/${PN}-1.2-cron.deny" cron.deny
-
- insinto /etc/cron.d
- doins contrib/{0hourly,dailyjobs}
-
- newinitd "${FILESDIR}/${PN}-1.3-initd" ${PN}
-
- if use pam ; then
- newpamd "${FILESDIR}/${PN}-1.4.3-pamd" crond
- fi
-
- systemd_newunit contrib/cronie.systemd cronie.service
-
- if use anacron ; then
- local anacrondir="/var/spool/anacron"
- keepdir ${anacrondir}
- fowners root:cron ${anacrondir}
- fperms 0750 ${anacrondir}
-
- insinto /etc
- doins contrib/anacrontab
-
- insinto /etc/cron.hourly
- doins contrib/0anacron
- fperms 0750 /etc/cron.hourly/0anacron
- fi
-
- einstalldocs
-}
-
-pkg_postinst() {
- cron_pkg_postinst
-
- if [[ -n "${REPLACING_VERSIONS}" ]] ; then
- ewarn "You should restart ${PN} daemon or else you might experience segfaults"
- ewarn "or ${PN} not working reliably anymore."
- einfo "(see https://bugs.gentoo.org/557406 for details.)"
- fi
-}
diff --git a/sys-process/cronie/files/cronie-1.5.3-systemd.patch b/sys-process/cronie/files/cronie-1.5.3-systemd.patch
deleted file mode 100644
index 0aed5404d39a..000000000000
--- a/sys-process/cronie/files/cronie-1.5.3-systemd.patch
+++ /dev/null
@@ -1,33 +0,0 @@
-From d022f457d838251963b23697d7ec907d43b637ac Mon Sep 17 00:00:00 2001
-From: Mike Gilbert <floppym@gentoo.org>
-Date: Sat, 16 Mar 2019 20:57:37 +0100
-Subject: [PATCH] Adjust systemd service unit for Gentoo
-
-forward-ported to v1.5.3 by Lars Wendler <polynomial-c@gentoo.org>
----
- contrib/cronie.systemd | 5 +++--
- 1 file changed, 3 insertions(+), 2 deletions(-)
-
-diff --git a/contrib/cronie.systemd b/contrib/cronie.systemd
-index 19f2a98..6f4c608 100644
---- a/contrib/cronie.systemd
-+++ b/contrib/cronie.systemd
-@@ -3,12 +3,13 @@ Description=Command Scheduler
- After=auditd.service nss-user-lookup.target systemd-user-sessions.service time-sync.target ypbind.service autofs.service
-
- [Service]
--EnvironmentFile=/etc/sysconfig/crond
--ExecStart=/usr/sbin/crond -n $CRONDARGS
-+ExecStart=/usr/sbin/crond
- ExecReload=/bin/kill -HUP $MAINPID
- KillMode=process
- Restart=on-failure
- RestartSec=30s
-+Type=forking
-+PIDFile=/run/crond.pid
-
- [Install]
- WantedBy=multi-user.target
---
-2.21.0
-