summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2019-11-04 11:01:15 +0100
committerLars Wendler <polynomial-c@gentoo.org>2019-11-04 11:04:23 +0100
commit54974377b44222662668f819bedb25f581e7224c (patch)
tree688284a1144ed650f36ba1e2f9c199e72b986fd6 /sys-process/atop/files
parentsys-apps/rng-tools: x86 stable wrt bug #699172 (diff)
downloadgentoo-54974377b44222662668f819bedb25f581e7224c.tar.gz
gentoo-54974377b44222662668f819bedb25f581e7224c.tar.bz2
gentoo-54974377b44222662668f819bedb25f581e7224c.zip
sys-process/atop: Bump to version 2.5.0
Package-Manager: Portage-2.3.78, Repoman-2.3.17 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'sys-process/atop/files')
-rw-r--r--sys-process/atop/files/atop-2.5.0-install_fix.patch31
1 files changed, 31 insertions, 0 deletions
diff --git a/sys-process/atop/files/atop-2.5.0-install_fix.patch b/sys-process/atop/files/atop-2.5.0-install_fix.patch
new file mode 100644
index 000000000000..b46e88c76f3c
--- /dev/null
+++ b/sys-process/atop/files/atop-2.5.0-install_fix.patch
@@ -0,0 +1,31 @@
+From 485a453d2ae5700874a57dffc297030254b5ae7c Mon Sep 17 00:00:00 2001
+From: BlackEagle <ike.devolder@gmail.com>
+Date: Mon, 4 Nov 2019 09:00:54 +0100
+Subject: [PATCH] DEFPATH not created so touch fails
+
+```
+touch /build/atop/pkg/atop/etc/default/atop
+touch: cannot touch '/build/atop/pkg/atop/etc/default/atop': No such file or directory
+```
+
+Add DEFPATH mkdir in genericinstall to make sure the folder
+`$(DESTDIR)/etc/default` exits
+
+Signed-off-by: BlackEagle <ike.devolder@gmail.com>
+---
+ Makefile | 2 ++
+ 1 file changed, 2 insertions(+)
+
+diff --git a/Makefile b/Makefile
+index 929b0d7..a662fd6 100644
+--- a/Makefile
++++ b/Makefile
+@@ -140,6 +140,8 @@ sysvinstall: genericinstall
+ genericinstall: atop atopacctd atopconvert
+ if [ ! -d $(DESTDIR)$(LOGPATH) ]; \
+ then mkdir -p $(DESTDIR)$(LOGPATH); fi
++ if [ ! -d $(DESTDIR)$(DEFPATH) ]; \
++ then mkdir -p $(DESTDIR)$(DEFPATH); fi
+ if [ ! -d $(DESTDIR)$(BINPATH) ]; \
+ then mkdir -p $(DESTDIR)$(BINPATH); fi
+ if [ ! -d $(DESTDIR)$(SBINPATH) ]; \