summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2018-01-18 22:09:30 +0100
committerMichał Górny <mgorny@gentoo.org>2018-01-18 22:25:09 +0100
commit20a83e1bcdd897bc7e284e228354c0534830e25d (patch)
tree92a96926d35ece2c93d85706f4dcbb1d7c0e356c /sys-libs/llvm-libunwind
parentsys-libs/libcxxabi: Drop old (5.0.0) (diff)
downloadgentoo-20a83e1bcdd897bc7e284e228354c0534830e25d.tar.gz
gentoo-20a83e1bcdd897bc7e284e228354c0534830e25d.tar.bz2
gentoo-20a83e1bcdd897bc7e284e228354c0534830e25d.zip
sys-libs/llvm-libunwind: Drop old (5.0.0)
Diffstat (limited to 'sys-libs/llvm-libunwind')
-rw-r--r--sys-libs/llvm-libunwind/Manifest1
-rw-r--r--sys-libs/llvm-libunwind/llvm-libunwind-5.0.0.ebuild46
2 files changed, 0 insertions, 47 deletions
diff --git a/sys-libs/llvm-libunwind/Manifest b/sys-libs/llvm-libunwind/Manifest
index ede9f443ed87..d4b6ec238b5a 100644
--- a/sys-libs/llvm-libunwind/Manifest
+++ b/sys-libs/llvm-libunwind/Manifest
@@ -2,5 +2,4 @@ DIST libunwind-3.8.1.src.tar.xz 60596 BLAKE2B e200beab1388dc73a4ed6b1be0c4931124
DIST libunwind-3.9.0.src.tar.xz 61764 BLAKE2B 215aa7cabf9e5d8d3e3dfc3bad50f0aad1b4d2d6bef96ac4c14d987b6aa4afd0a1c0f186d63d84edcc822fd8495a000b2a24899e61176831e0ddfabea1d5c3c2 SHA512 dce384bea99ed61b363b847e20946fc9d70377389a227cc7054fbaa916e7cb5ba0b9d89f0df6ed33409dbf38beefd3654c18c1abcf0e50b5d0315ce0135a1d25
DIST libunwind-3.9.1.src.tar.xz 61788 BLAKE2B bab410d714e2dc012273997bb3fb3c366f64608b712eae15f8c08a2b049b6bdba0660a1f4942906e2e9cd7b11563c8a5b3007b92b1485c32036ac84f55fe7053 SHA512 a80f5d0660e209f5bf709316b5df2ca63b9f0db49f5f74dfe9c9e580c654f61a15acc071a739fdb84baf5ffa9420b92498f8560331173642d80f6b74e1e2afb7
DIST libunwind-4.0.1.src.tar.xz 63388 BLAKE2B f49772beabaa8519a5f8dbbaef9c2d6554468a66b89a5f012946d59f772fe864809a5c95b726bcb4c059ca551a4eb023a88f4fa618756b34fef2058e272467e6 SHA512 8a0552a8ab830010d81420f4b778a3b831bff85b19bcce972958fc30e1ba5a2fa26a3deba499985a43dd7a103690775f6a20e7b3edda55f4eaff3541002d6b59
-DIST libunwind-5.0.0.src.tar.xz 72236 BLAKE2B 814fc20402e62c783c61a11b36f00b430a38d673ba810178ca35a70880c5d2455956aa6e84c3cb796e7f4fc3d6b9352fd75dac575a47d38cffd248c2b143f699 SHA512 20d54d5342d67425f5e36e9c690f1bb67bc2a3b7184b3ad546b689e510728d7c596f178d4f5186daf7480409ed4e455848b4ad1d9d896370fac1db69885fc793
DIST libunwind-5.0.1.src.tar.xz 72180 BLAKE2B da1fbb92e9953d018a3c30290ceda9a2a18c21b5c908d9ff65979158bd06b8866eb74f078d12832e2aed7d0332c996262e3b2a1341844eb933ba3de5fb41ff98 SHA512 6c0f7a286c1ffa46769685ee36604cd90ed40470e1c3d3ef03c46bcc9e5f9e36e68a0a1f67b9b300823170b48c9b8d2db4625afd885f1d024905db1dffd9fc49
diff --git a/sys-libs/llvm-libunwind/llvm-libunwind-5.0.0.ebuild b/sys-libs/llvm-libunwind/llvm-libunwind-5.0.0.ebuild
deleted file mode 100644
index a85458427d14..000000000000
--- a/sys-libs/llvm-libunwind/llvm-libunwind-5.0.0.ebuild
+++ /dev/null
@@ -1,46 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-: ${CMAKE_MAKEFILE_GENERATOR:=ninja}
-# (needed due to CMAKE_BUILD_TYPE != Gentoo)
-CMAKE_MIN_VERSION=3.7.0-r1
-inherit cmake-multilib llvm
-
-DESCRIPTION="C++ runtime stack unwinder from LLVM"
-HOMEPAGE="https://github.com/llvm-mirror/libunwind"
-SRC_URI="https://releases.llvm.org/${PV/_//}/libunwind-${PV/_/}.src.tar.xz"
-
-LICENSE="|| ( UoI-NCSA MIT )"
-SLOT="0"
-KEYWORDS="~amd64 ~arm64 ~x86"
-IUSE="debug +static-libs"
-
-RDEPEND="!sys-libs/libunwind"
-# LLVM 4 required for llvm-config --cmakedir
-DEPEND=">=sys-devel/llvm-4"
-
-S=${WORKDIR}/libunwind-${PV/_/}.src
-
-# least intrusive of all
-CMAKE_BUILD_TYPE=RelWithDebInfo
-
-multilib_src_configure() {
- local libdir=$(get_libdir)
-
- local mycmakeargs=(
- -DLLVM_LIBDIR_SUFFIX=${libdir#lib}
- -DLIBUNWIND_ENABLE_ASSERTIONS=$(usex debug)
- -DLIBUNWIND_ENABLE_STATIC=$(usex static-libs)
- )
-
- cmake-utils_src_configure
-}
-
-multilib_src_install() {
- cmake-utils_src_install
-
- # install headers like sys-libs/libunwind
- doheader "${S}"/include/*.h
-}