summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorgy Yakovlev <gyakovlev@gentoo.org>2020-08-30 15:49:41 -0700
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2020-08-30 15:49:56 -0700
commit590917dadcf1f332666a31ec18e02776d3a00e14 (patch)
tree330e8e39bb6801e38833eb0efe97857a65c764ef /sys-fs/zfs
parentdev-libs/nss: Stabilize 3.55 ppc64, #734986 (diff)
downloadgentoo-590917dadcf1f332666a31ec18e02776d3a00e14.tar.gz
gentoo-590917dadcf1f332666a31ec18e02776d3a00e14.tar.bz2
gentoo-590917dadcf1f332666a31ec18e02776d3a00e14.zip
sys-fs/zfs: backport new systemd message to releases
Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
Diffstat (limited to 'sys-fs/zfs')
-rw-r--r--sys-fs/zfs/zfs-0.8.4-r2.ebuild21
-rw-r--r--sys-fs/zfs/zfs-2.0.0_rc1-r1.ebuild21
2 files changed, 26 insertions, 16 deletions
diff --git a/sys-fs/zfs/zfs-0.8.4-r2.ebuild b/sys-fs/zfs/zfs-0.8.4-r2.ebuild
index 6b30ef219ee4..5501d0e9c675 100644
--- a/sys-fs/zfs/zfs-0.8.4-r2.ebuild
+++ b/sys-fs/zfs/zfs-0.8.4-r2.ebuild
@@ -201,14 +201,19 @@ pkg_postinst() {
update_moduledb
fi
- [[ -e "${EROOT}/etc/runlevels/boot/zfs-import" ]] || \
- einfo "You should add zfs-import to the boot runlevel."
- [[ -e "${EROOT}/etc/runlevels/boot/zfs-mount" ]]|| \
- einfo "You should add zfs-mount to the boot runlevel."
- [[ -e "${EROOT}/etc/runlevels/default/zfs-share" ]] || \
- einfo "You should add zfs-share to the default runlevel."
- [[ -e "${EROOT}/etc/runlevels/default/zfs-zed" ]] || \
- einfo "You should add zfs-zed to the default runlevel."
+ if systemd_is_booted || has_version sys-apps/systemd; then
+ einfo "Please refer to ${EROOT}/lib/systemd/system-preset/50-zfs.preset"
+ einfo "for default zfs systemd service configuration"
+ else
+ [[ -e "${EROOT}/etc/runlevels/boot/zfs-import" ]] || \
+ einfo "You should add zfs-import to the boot runlevel."
+ [[ -e "${EROOT}/etc/runlevels/boot/zfs-mount" ]]|| \
+ einfo "You should add zfs-mount to the boot runlevel."
+ [[ -e "${EROOT}/etc/runlevels/default/zfs-share" ]] || \
+ einfo "You should add zfs-share to the default runlevel."
+ [[ -e "${EROOT}/etc/runlevels/default/zfs-zed" ]] || \
+ einfo "You should add zfs-zed to the default runlevel."
+ fi
}
pkg_postrm() {
diff --git a/sys-fs/zfs/zfs-2.0.0_rc1-r1.ebuild b/sys-fs/zfs/zfs-2.0.0_rc1-r1.ebuild
index 55317293ed4b..486de47acc47 100644
--- a/sys-fs/zfs/zfs-2.0.0_rc1-r1.ebuild
+++ b/sys-fs/zfs/zfs-2.0.0_rc1-r1.ebuild
@@ -206,14 +206,19 @@ pkg_postinst() {
update_moduledb
fi
- [[ -e "${EROOT}/etc/runlevels/boot/zfs-import" ]] || \
- einfo "You should add zfs-import to the boot runlevel."
- [[ -e "${EROOT}/etc/runlevels/boot/zfs-mount" ]]|| \
- einfo "You should add zfs-mount to the boot runlevel."
- [[ -e "${EROOT}/etc/runlevels/default/zfs-share" ]] || \
- einfo "You should add zfs-share to the default runlevel."
- [[ -e "${EROOT}/etc/runlevels/default/zfs-zed" ]] || \
- einfo "You should add zfs-zed to the default runlevel."
+ if systemd_is_booted || has_version sys-apps/systemd; then
+ einfo "Please refer to ${EROOT}/lib/systemd/system-preset/50-zfs.preset"
+ einfo "for default zfs systemd service configuration"
+ else
+ [[ -e "${EROOT}/etc/runlevels/boot/zfs-import" ]] || \
+ einfo "You should add zfs-import to the boot runlevel."
+ [[ -e "${EROOT}/etc/runlevels/boot/zfs-mount" ]]|| \
+ einfo "You should add zfs-mount to the boot runlevel."
+ [[ -e "${EROOT}/etc/runlevels/default/zfs-share" ]] || \
+ einfo "You should add zfs-share to the default runlevel."
+ [[ -e "${EROOT}/etc/runlevels/default/zfs-zed" ]] || \
+ einfo "You should add zfs-zed to the default runlevel."
+ fi
}
pkg_postrm() {