summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <m.mairkeimberger@gmail.com>2018-07-12 11:14:06 +0200
committerMichał Górny <mgorny@gentoo.org>2018-08-15 13:50:34 +0200
commitd6404e990970ba7afb5ee20c38ff1d1752565f45 (patch)
treef2000ef1d7ba2628179bffe520750061a67c53aa /sys-fs/treesize
parentcmake-utils.eclass: EAPI future-proof inherit-stop (diff)
downloadgentoo-d6404e990970ba7afb5ee20c38ff1d1752565f45.tar.gz
gentoo-d6404e990970ba7afb5ee20c38ff1d1752565f45.tar.bz2
gentoo-d6404e990970ba7afb5ee20c38ff1d1752565f45.zip
sys-fs/treesize: EAPI7, improve ebuild
Closes: https://github.com/gentoo/gentoo/pull/9197
Diffstat (limited to 'sys-fs/treesize')
-rw-r--r--sys-fs/treesize/files/0.54.1-amd64.patch4
-rw-r--r--sys-fs/treesize/treesize-0.54.1-r1.ebuild24
2 files changed, 26 insertions, 2 deletions
diff --git a/sys-fs/treesize/files/0.54.1-amd64.patch b/sys-fs/treesize/files/0.54.1-amd64.patch
index d7d9d787ad39..c03df8a258e7 100644
--- a/sys-fs/treesize/files/0.54.1-amd64.patch
+++ b/sys-fs/treesize/files/0.54.1-amd64.patch
@@ -1,5 +1,5 @@
---- src/ui-util.c 2007-11-16 22:08:01.000000000 +0100
-+++ src/ui-util.c.new 2009-05-09 11:34:59.000000000 +0200
+--- a/src/ui-util.c 2007-11-16 22:08:01.000000000 +0100
++++ b/src/ui-util.c 2009-05-09 11:34:59.000000000 +0200
@@ -18,6 +18,7 @@
#include "ui-util.h"
diff --git a/sys-fs/treesize/treesize-0.54.1-r1.ebuild b/sys-fs/treesize/treesize-0.54.1-r1.ebuild
new file mode 100644
index 000000000000..b80f570f87e3
--- /dev/null
+++ b/sys-fs/treesize/treesize-0.54.1-r1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+DESCRIPTION="A disk consumption analyzing tool"
+HOMEPAGE="http://treesize.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}-src.tbz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="x11-libs/gtk+:2"
+DEPEND="${RDEPEND}"
+
+PATCHES=( "${FILESDIR}/${PV}-amd64.patch" )
+
+src_prepare() {
+ default
+ eautoreconf
+}