summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-06-16 21:07:10 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2019-06-16 23:57:07 +0200
commit82edda722cbfdcdb1e5448087a833695954e9dae (patch)
treee48fc68645d051c2308fec13cae43b6840b4220c /sys-fs/cryfs
parentsys-fs/cryfs: Add linux-info for CONFIG_FUSE_FS check (diff)
downloadgentoo-82edda722cbfdcdb1e5448087a833695954e9dae.tar.gz
gentoo-82edda722cbfdcdb1e5448087a833695954e9dae.tar.bz2
gentoo-82edda722cbfdcdb1e5448087a833695954e9dae.zip
sys-fs/cryfs: Drop 0.9.7
Package-Manager: Portage-2.3.67, Repoman-2.3.14 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'sys-fs/cryfs')
-rw-r--r--sys-fs/cryfs/Manifest2
-rw-r--r--sys-fs/cryfs/cryfs-0.9.7.ebuild86
2 files changed, 0 insertions, 88 deletions
diff --git a/sys-fs/cryfs/Manifest b/sys-fs/cryfs/Manifest
index 3889148971d5..ff47d4c00674 100644
--- a/sys-fs/cryfs/Manifest
+++ b/sys-fs/cryfs/Manifest
@@ -1,3 +1 @@
-DIST cryfs-0.9.7-spdlog.patch.xz 28204 BLAKE2B 0905971713b2d709aa34bfd11333a0aaea21ba08bbed12eee20e668fae4c19b17fe25d2fecf17dfff67abadd896b5e3eda2344655e2fb32ea1f28961d850d158 SHA512 a09adf3d9ce47bd38bfc9e3b35f23df8ce971e6d115d7e6eaa907c7eab71e73d495bda9d1ab96e25b4a9a9d551fa07a71f37d17c9779679b3a95dfff1d311a86
-DIST cryfs-0.9.7.tar.xz 970588 BLAKE2B b3d79ed44c2280ef34bafa5613f51918093686da9a4637987745bd9601817033049115754e235b9a9a0f2045401182bc9cb48291173df6571887e9dec3f73636 SHA512 962c7e5e7ea153ed41cb47094b71bc41457e26203b94cc5e349c4d21e86630e32113c0193a248eee8ead41bede1c712d4c006150f84a6e1c2a0a0a7c02a1911b
DIST cryfs-0.9.9.tar.xz 977928 BLAKE2B 927d5f61be99a6400cfd53de6291e14ae32f446d281485901e758341f138a2efdfb7385b6c205db6f865dc83f6fbd9ede8fd1bb5a7957fb242624d78d2523eaf SHA512 18f0ce954dc9958b52a77aac85d4d30d03409e4f88c27ec3e904a6014f5257e12fe47a4f3bb628f6ebf3b5aa8cb9d3a59e0aee76d83a3f6bdd4ef864b66898aa
diff --git a/sys-fs/cryfs/cryfs-0.9.7.ebuild b/sys-fs/cryfs/cryfs-0.9.7.ebuild
deleted file mode 100644
index fa5832c7cd9f..000000000000
--- a/sys-fs/cryfs/cryfs-0.9.7.ebuild
+++ /dev/null
@@ -1,86 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-CMAKE_MAKEFILE_GENERATOR=emake
-PYTHON_COMPAT=( python{2_7,3_{5,6}} )
-
-inherit cmake-utils python-any-r1
-
-DESCRIPTION="Encrypted FUSE filesystem that conceals metadata"
-HOMEPAGE="https://www.cryfs.org/"
-
-SLOT=0
-IUSE="libressl test update-check"
-
-LICENSE="LGPL-3 BSD-2 MIT"
-# cryfs - LGPL-3
-# scrypt - BSD-2
-# spdlog - MIT
-
-if [[ "${PV}" == 9999 ]] ; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/cryfs/cryfs"
-else
- SRC_URI="https://github.com/cryfs/cryfs/releases/download/${PV}/${P}.tar.xz
- https://dev.gentoo.org/~johu/distfiles/${P}-spdlog.patch.xz"
- KEYWORDS="amd64 ~arm x86"
- S="${WORKDIR}"
-fi
-
-RDEPEND=">=dev-libs/boost-1.56:=
- >=dev-libs/crypto++-5.6.3:=
- net-misc/curl:=
- >=sys-fs/fuse-2.8.6:=
- !libressl? ( dev-libs/openssl:0= )
- libressl? ( dev-libs/libressl:= )"
-DEPEND="${RDEPEND}
- ${PYTHON_DEPS}"
-
-PATCHES=( "${WORKDIR}/${P}-spdlog.patch" )
-
-# tests work, but let install fail
-# revisit with 0.9.8 version bump.
-RESTRICT="test"
-
-src_prepare() {
- cmake-utils_src_prepare
-
- # remove tests that require internet access to comply with Gentoo policy
- sed -i -e '/CurlHttpClientTest.cpp/d' -e '/FakeHttpClientTest.cpp/d' test/cpp-utils/CMakeLists.txt || die
-
- # remove non-applicable warning
- sed -i -e '/WARNING! This is a debug build. Performance might be slow./d' src/cryfs-cli/Cli.cpp || die
-}
-
-src_configure() {
- # upstream restricts installing files to Release configuration
- # (CMAKE_BUILD_TYPE does not affect anything else)
- local CMAKE_BUILD_TYPE=Release
- local mycmakeargs=(
- "-DBoost_USE_STATIC_LIBS=off"
- "-DCRYFS_UPDATE_CHECKS=$(usex update-check)"
- "-DBUILD_TESTING=$(usex test)"
- )
-
- cmake-utils_src_configure
-}
-
-src_test() {
- local TMPDIR="${T}"
- addread /dev/fuse
- addwrite /dev/fuse
- local tests_failed=()
-
- for i in gitversion cpp-utils parallelaccessstore blockstore blobstore fspp cryfs cryfs-cli ; do
- "${BUILD_DIR}"/test/${i}/${i}-test || tests_failed+=( "${i}" )
- done
-
- adddeny /dev/fuse
-
- if [[ -n ${tests_failed[@]} ]] ; then
- eerror "The following tests failed:"
- eerror "$tests_failed[@]"
- die "At least one test failed"
- fi
-}