summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2016-02-19 09:08:51 +0100
committerJustin Lecher <jlec@gentoo.org>2016-02-19 09:18:59 +0100
commit37b6efdafc262d8f17f97fc4f3c96fe08fff0326 (patch)
tree81af7d291d5b89f77a0b31790f158e6729da5441 /sys-fs/aufs4
parentsys-fs/aufs4: Drop old (diff)
downloadgentoo-37b6efdafc262d8f17f97fc4f3c96fe08fff0326.tar.gz
gentoo-37b6efdafc262d8f17f97fc4f3c96fe08fff0326.tar.bz2
gentoo-37b6efdafc262d8f17f97fc4f3c96fe08fff0326.zip
sys-fs/aufs4: Bump to latest aufs release
* Bump to EAPI=6 * Bump to nextgen readme.gentoo eclass * Try to break lines at 80 chars Package-Manager: portage-2.2.27 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'sys-fs/aufs4')
-rw-r--r--sys-fs/aufs4/Manifest2
-rw-r--r--sys-fs/aufs4/aufs4-0_pre20160219.ebuild (renamed from sys-fs/aufs4/aufs4-0_pre20160215.ebuild)63
2 files changed, 41 insertions, 24 deletions
diff --git a/sys-fs/aufs4/Manifest b/sys-fs/aufs4/Manifest
index 9b1c5a3d8b74..e8b933e4bb61 100644
--- a/sys-fs/aufs4/Manifest
+++ b/sys-fs/aufs4/Manifest
@@ -1 +1 @@
-DIST aufs4-standalone-0_pre20160215.tar.xz 931276 SHA256 2303db1f8116762baf0aeadb8191c0bf9ed00380a5855b2297c92716a50fc2aa SHA512 e07dee042700edb6c4aafc995910181b59067e5a62d8bdcbb8992efdd1f5afcb0d38322e85a0efe57dfee465c0e74bb597928fb3bbf5db86c4d2007a9fd88c46 WHIRLPOOL ef611cbf47204b9691bd432a83898e5543754dcdf5597a18fb0327f3b269f3c7cfcfc2e0a46bc0ec0952eee114508d81decfa59c03a683a74292d123c24bea3d
+DIST aufs4-standalone-0_pre20160219.tar.xz 1049884 SHA256 22d0f723ff52190670da0e3dc4a3f0b81ba0b3b6f287484cf81165c6cd4b2040 SHA512 95999199ac0d430a6ab2dbda75f34d9640179865d5be3b1db119c1e613f5bd167193dd7cf662ebcea9d81ad8008d9dbd8dd835d5a7a297456f8587364e7f16b1 WHIRLPOOL a8b7a9c80c7715d0f75c9ee15e78bfbef2db11d4d9fea6ac1e8163f86b735c57b7e6a5612ac269fbcc2c483537a06c1e7704b9c3db2c7dff09b08d228ba607a1
diff --git a/sys-fs/aufs4/aufs4-0_pre20160215.ebuild b/sys-fs/aufs4/aufs4-0_pre20160219.ebuild
index 08283b50ae37..ada01474fea3 100644
--- a/sys-fs/aufs4/aufs4-0_pre20160215.ebuild
+++ b/sys-fs/aufs4/aufs4-0_pre20160219.ebuild
@@ -2,15 +2,15 @@
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=5
+EAPI=6
-inherit eutils flag-o-matic linux-info linux-mod multilib readme.gentoo toolchain-funcs
+inherit eutils flag-o-matic linux-info linux-mod multilib readme.gentoo-r1 toolchain-funcs
AUFS_VERSION="${PV%%_p*}"
# highest branch version
-PATCH_MAX_VER=3
+PATCH_MAX_VER=4
# highest supported version
-KERN_MAX_VER=4
+KERN_MAX_VER=5
# lowest supported version
KERN_MIN_VER=0
@@ -42,13 +42,16 @@ pkg_setup() {
use nfs && CONFIG_CHECK+=" EXPORTFS"
use fuse && CONFIG_CHECK+=" ~FUSE_FS"
use hfs && CONFIG_CHECK+=" ~HFSPLUS_FS"
- use pax_kernel && CONFIG_CHECK+=" PAX" && ERROR_PAX="Please use hardened sources"
+ use pax_kernel && CONFIG_CHECK+=" PAX" \
+ && ERROR_PAX="Please use hardened sources"
- # this is needed so merging a binpkg ${PN} is possible w/out a kernel unpacked on the system
- [ -n "$PKG_SETUP_HAS_BEEN_RAN" ] && return
+ # this is needed so merging a binpkg ${PN} is
+ # possible w/out a kernel unpacked on the system
+ [[ -n "$PKG_SETUP_HAS_BEEN_RAN" ]] && return
get_version
- kernel_is lt 4 ${KERN_MIN_VER} 0 && die "the kernel version isn't supported by upstream anymore. Please upgrade."
+ kernel_is lt 4 ${KERN_MIN_VER} 0 && \
+ die "the kernel version isn't supported by upstream anymore. Please upgrade."
kernel_is gt 4 ${KERN_MAX_VER} 99 && die "kernel too new"
linux-mod_pkg_setup
@@ -72,19 +75,30 @@ pkg_setup() {
;;
esac
- pushd "${T}" &> /dev/null
+ pushd "${T}" &> /dev/null || die
unpack ${A}
+
cd ${PN}-standalone || die
+
local module_branch=origin/${PN}.${PATCH_BRANCH}
+
einfo "Using ${module_branch} as patch source"
git checkout -q -b local-${PN}.${PATCH_BRANCH} ${module_branch} || die
- combinediff ${PN}-base.patch ${PN}-standalone.patch > "${T}"/combined-1.patch
- combinediff "${T}"/combined-1.patch ${PN}-mmap.patch > ${PN}-standalone-base-mmap-combined.patch
+
+ combinediff \
+ ${PN}-base.patch ${PN}-standalone.patch > "${T}"/combined-1.patch
+ combinediff \
+ "${T}"/combined-1.patch ${PN}-mmap.patch \
+ > ${PN}-standalone-base-mmap-combined.patch
+
if ! ( patch -p1 --dry-run --force -R -d ${KV_DIR} < ${PN}-standalone-base-mmap-combined.patch > /dev/null ); then
if use kernel-patch; then
cd ${KV_DIR}
ewarn "Patching your kernel..."
- patch --no-backup-if-mismatch --force -p1 -R -d ${KV_DIR} < "${T}"/${PN}-standalone/${PN}-standalone-base-mmap-combined.patch >/dev/null
+ patch \
+ --no-backup-if-mismatch --force -p1 -R -d ${KV_DIR} \
+ < "${T}"/${PN}-standalone/${PN}-standalone-base-mmap-combined.patch \
+ > /dev/null
epatch "${T}"/${PN}-standalone/${PN}-standalone-base-mmap-combined.patch
ewarn "You need to compile your kernel with the applied patch"
ewarn "to be able to load and use the aufs kernel module"
@@ -95,13 +109,15 @@ pkg_setup() {
die "missing kernel patch, please apply it first"
fi
fi
+
popd &> /dev/null
export PKG_SETUP_HAS_BEEN_RAN=1
}
set_config() {
for option in $*; do
- grep -q "^CONFIG_AUFS_${option} =" config.mk || die "${option} is not a valid config option"
+ grep -q "^CONFIG_AUFS_${option} =" config.mk || \
+ die "${option} is not a valid config option"
sed "/^CONFIG_AUFS_${option}/s:=:= y:g" -i config.mk || die
done
}
@@ -125,11 +141,11 @@ src_prepare() {
use nfs && ( use amd64 || use ppc64 ) && set_config INO_T_64
use ramfs && set_config BR_RAMFS
- if use pax_kernel; then
- epatch "${FILESDIR}"/pax-4.patch
- fi
+ use pax_kernel && epatch "${FILESDIR}"/pax-4.patch
- sed -i "s:aufs.ko usr/include/linux/aufs_type.h:aufs.ko:g" Makefile || die
+ sed \
+ -e "s:aufs.ko usr/include/linux/aufs_type.h:aufs.ko:g" \
+ -i Makefile || die
}
src_compile() {
@@ -147,18 +163,19 @@ src_compile() {
src_install() {
linux-mod_src_install
- insinto /usr/share/doc/${PF}
-
- use doc && doins -r Documentation
+ use doc && dodoc -r Documentation
- use kernel-patch || doins "${T}"/${PN}-standalone/${PN}-standalone-base-mmap-combined.patch
+ use kernel-patch || \
+ doins "${T}"/${PN}-standalone/${PN}-standalone-base-mmap-combined.patch
- dodoc Documentation/filesystems/aufs/README "${T}"/${PN}-standalone/{aufs4-loopback,vfs-ino,tmpfs-idr}.patch
+ dodoc \
+ Documentation/filesystems/aufs/README \
+ "${T}"/${PN}-standalone/{aufs4-loopback,vfs-ino,tmpfs-idr}.patch
readme.gentoo_create_doc
}
pkg_postinst() {
- readme.gentoo_pkg_postinst
+ readme.gentoo_print_elog
linux-mod_pkg_postinst
}