summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-11-10 12:43:36 +0100
committerMichał Górny <mgorny@gentoo.org>2019-11-10 13:05:44 +0100
commitdf5619fcc7f93558f4dc145492725748bad550ed (patch)
treedb9bb4c2d8d104d2fe72de5670114ce46f8775e9 /sys-fs/arm-fdisk
parentdev-vcs/cvsps: refresh up to EAPI=7 (diff)
downloadgentoo-df5619fcc7f93558f4dc145492725748bad550ed.tar.gz
gentoo-df5619fcc7f93558f4dc145492725748bad550ed.tar.bz2
gentoo-df5619fcc7f93558f4dc145492725748bad550ed.zip
sys-fs/arm-fdisk: Bump to EAPI 7
Closes: https://bugs.gentoo.org/697162 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sys-fs/arm-fdisk')
-rw-r--r--sys-fs/arm-fdisk/arm-fdisk-3.0.6-r1.ebuild24
1 files changed, 10 insertions, 14 deletions
diff --git a/sys-fs/arm-fdisk/arm-fdisk-3.0.6-r1.ebuild b/sys-fs/arm-fdisk/arm-fdisk-3.0.6-r1.ebuild
index 3a85f525491e..aaafaf93c51b 100644
--- a/sys-fs/arm-fdisk/arm-fdisk-3.0.6-r1.ebuild
+++ b/sys-fs/arm-fdisk/arm-fdisk-3.0.6-r1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=0
+EAPI=7
-inherit eutils toolchain-funcs
+inherit toolchain-funcs
DEB_VER=6.2
DESCRIPTION="edit disk partitions on Acorn machines"
@@ -16,30 +16,26 @@ SLOT="0"
KEYWORDS="alpha amd64 arm hppa ia64 m68k ~mips ppc s390 sh sparc x86"
IUSE=""
-DEPEND=""
+src_prepare() {
+ default
+ eapply "${WORKDIR}"/acorn-fdisk_${PV}-${DEB_VER}.diff
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${WORKDIR}"/acorn-fdisk_${PV}-${DEB_VER}.diff
-
- find "${S}" -name Makefile -print0 | xargs -0 \
- sed -i \
+ find . -name Makefile -exec sed -i \
-e "s:-O2 -Wall\( -g\)\?::" \
-e "/^CFLAGS/s:=:+=:" \
-e "/^LDFLAGS/s:=:+=:" \
- -e '/^STRIP/s:strip:true:'
+ -e '/^STRIP/s:strip:true:' {} + || die
}
src_compile() {
emake \
CC="$(tc-getCC)" \
- AR="$(tc-getAR)" || die
+ AR="$(tc-getAR)"
}
src_install() {
into /
- newsbin fdisk ${PN} || die "sbin failed"
+ newsbin fdisk ${PN}
dosym ${PN} /sbin/acorn-fdisk
dodoc ChangeLog README debian/changelog
}