summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2024-07-18 20:39:54 +0200
committerPacho Ramos <pacho@gentoo.org>2024-07-18 21:02:57 +0200
commit08704e2f17945bcb4ba9ffec01764427992f3938 (patch)
treec15342caca3ac82962a7395c371335d190ec2cb9 /sys-firmware
parentnet-libs/nodejs: drop failing test for 32 bit platforms (diff)
downloadgentoo-08704e2f17945bcb4ba9ffec01764427992f3938.tar.gz
gentoo-08704e2f17945bcb4ba9ffec01764427992f3938.tar.bz2
gentoo-08704e2f17945bcb4ba9ffec01764427992f3938.zip
sys-firmware/sof-firmware: add 2024.06
Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Diffstat (limited to 'sys-firmware')
-rw-r--r--sys-firmware/sof-firmware/Manifest1
-rw-r--r--sys-firmware/sof-firmware/sof-firmware-2024.06.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/sys-firmware/sof-firmware/Manifest b/sys-firmware/sof-firmware/Manifest
index 3069daf66e4f..05ff1cba04a2 100644
--- a/sys-firmware/sof-firmware/Manifest
+++ b/sys-firmware/sof-firmware/Manifest
@@ -1,3 +1,4 @@
DIST sof-firmware-2023.12.1.tar.gz 5446189 BLAKE2B a901637ba25df51152f04c7db5330b70a18c92363b102c061568a4c3a8a7e2fc506ac9783abe715f680a27be8a040d63b7dd5b62682979ccf1e4eaeb30789d83 SHA512 e0175f3af5336f23548efcf8fa302bafbb6122fd173273203f687c05ee17fab4e7bd457b27cc7a62fd25ea77708ffdbf9e1fe3880d3df1cf2196d7073c6f7677
DIST sof-firmware-2023.12.tar.gz 5427762 BLAKE2B 48169378609119555f9b655599cef55e5722be71fdfc8fb71b699188fcb3f62a68e217fc3fec8859cd3e1c252f046208d5123c961dd824bd9b6559bd1fb72325 SHA512 ed43e7597c93140b15499ba17bae1866dcf1e2959d910e81b3831e4db2224a1dcff790ef21afcd610d7cc9309251a08351bae1c959ded18e5e28a6b24ae99506
DIST sof-firmware-2024.03.tar.gz 8161590 BLAKE2B 23d73ff3ab30b5134086bb21e606805a7d9667adf1a5598a3d31068ba0254dc4c34464ee3913eb3530a8124e3614eff9ba28fa731e9816b28980ea05834c1037 SHA512 1e9891d3891f5a4413a77a68ea6d3a2e6ead8c1a67eaa7e9aaf30871753617ffce19bd3b85ebcbb617e606646f6aa0e1dafee5279c294ec72ef4b2885e009f72
+DIST sof-firmware-2024.06.tar.gz 9848270 BLAKE2B 31189e81400981b76db585019324e7dec9f81ff488c6bbc575534d4968ea974764ecf0b585918cc1871e99ef8cff45f77c8c7509bb954360693f3a283b391d6a SHA512 50dbd849b086158af88dd629566b80de4e841dd8a74b6ea8b1d99b3321be94a0d2d6f742b557f0445b9618a6dbeee3fec6a4e9822b320d511ede1ec1812c0d4d
diff --git a/sys-firmware/sof-firmware/sof-firmware-2024.06.ebuild b/sys-firmware/sof-firmware/sof-firmware-2024.06.ebuild
new file mode 100644
index 000000000000..105eaae58f37
--- /dev/null
+++ b/sys-firmware/sof-firmware/sof-firmware-2024.06.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Sound Open Firmware (SOF) binary files"
+HOMEPAGE="https://www.sofproject.org https://github.com/thesofproject/sof https://github.com/thesofproject/sof-bin"
+SRC_URI="https://github.com/thesofproject/sof-bin/releases/download/v${PV}/sof-bin-${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}"/sof-bin-${PV}
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="+tools"
+
+RDEPEND="
+ tools? (
+ media-libs/alsa-lib
+ sys-libs/glibc
+ )
+"
+
+QA_PREBUILT="usr/bin/sof-ctl
+ usr/bin/sof-logger
+ usr/bin/sof-probes"
+
+src_install() {
+ dodir /lib/firmware/intel
+ dodir /usr/bin
+ FW_DEST="${D}/lib/firmware/intel" TOOLS_DEST="${D}/usr/bin" "${S}/install.sh" || die
+
+ # Drop tools if requested (i.e. useful for musl systems, where glibc
+ # is not available)
+ if ! use tools ; then
+ rm -rv "${D}"/usr/bin || die
+ fi
+}
+
+pkg_preinst() {
+ # Fix sof-ace-tplg directory symlink collisions
+ local sofpath="${EROOT}/lib/firmware/intel/sof-ace-tplg"
+ if [[ ! -L "${sofpath}" && -d "${sofpath}" ]] ; then
+ rm -r "${sofpath}" || die
+ fi
+}