summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2023-04-23 21:51:51 -0700
committerZac Medico <zmedico@gentoo.org>2023-04-23 22:58:20 -0700
commit2f2fe9f08b12035f4a9640a8d6d9fea9e8080127 (patch)
treea2dc68051a834f1c1ab9f26e0d471b7e33c24a25 /sys-fabric
parentdev-python/termcolor: Bump to 2.3.0 (diff)
downloadgentoo-2f2fe9f08b12035f4a9640a8d6d9fea9e8080127.tar.gz
gentoo-2f2fe9f08b12035f4a9640a8d6d9fea9e8080127.tar.bz2
gentoo-2f2fe9f08b12035f4a9640a8d6d9fea9e8080127.zip
sys-fabric/mstflint: add 4.23.0_p1
Closes: https://bugs.gentoo.org/904894 Signed-off-by: Zac Medico <zmedico@gentoo.org>
Diffstat (limited to 'sys-fabric')
-rw-r--r--sys-fabric/mstflint/Manifest1
-rw-r--r--sys-fabric/mstflint/files/mstflint-4.23.0_p1-C99-compat.patch55
-rw-r--r--sys-fabric/mstflint/mstflint-4.23.0_p1.ebuild49
3 files changed, 105 insertions, 0 deletions
diff --git a/sys-fabric/mstflint/Manifest b/sys-fabric/mstflint/Manifest
index f31f8e3f09a6..cfcd1e932dcd 100644
--- a/sys-fabric/mstflint/Manifest
+++ b/sys-fabric/mstflint/Manifest
@@ -1,2 +1,3 @@
DIST mstflint-4.18.0_p1.tar.gz 4877851 BLAKE2B 7fb995561155ccc73b0c36d2994c0398483a92788c5ce045f0263a3e5b0ff7230ca8bb0f5b821e957d5879e0629f11716b179e3bc581849335cc95715631c1d6 SHA512 aed2302dc88b9b95892eb6dd929a922ac6257ddae808db656c7fd01c393f9f0a0d3aa4e13da6c07fe0118cd48a43795f39cc16e619408b05e6bed7d085dbf0d4
DIST mstflint-4.20.0_p1.tar.gz 5176386 BLAKE2B 065fbf1884de70b57b602bb2a46e34c903b7419050622f2e6d55589f066555a43e781e35cfa4751f4d3af4394f3bbcff3c61e5618acb6696d0c22790ccaf50b8 SHA512 7298c425831f6e8f80145fb0f79af9d63ed013eeac6a99a5d9fe804a6e5c044ecffaf0ce62cd3edd07d185732bdb6ae3a99ecbb31b94047831d710b0b7fe1738
+DIST mstflint-4.23.0_p1.tar.gz 6269497 BLAKE2B 95c8fda6a1532baa50de7bcfffc128d24f30c41e670ee9fb19193025dee75fecf3b3e5bebec30bfd7ce9cc138c8eb61ba66a24d14ccec304cc75cae95d62995f SHA512 e0f98587272334d30910b7e8ea4c61ee0404924c85bfedd298ef0ae9321b177d56c8469588a2f59bc1584da79cd2908a222f3608b240d3b5498fb0cd87c06146
diff --git a/sys-fabric/mstflint/files/mstflint-4.23.0_p1-C99-compat.patch b/sys-fabric/mstflint/files/mstflint-4.23.0_p1-C99-compat.patch
new file mode 100644
index 000000000000..7b9b90ea9360
--- /dev/null
+++ b/sys-fabric/mstflint/files/mstflint-4.23.0_p1-C99-compat.patch
@@ -0,0 +1,55 @@
+From 3d033115fd0937b675b75f5d1fc12dc015efcf07 Mon Sep 17 00:00:00 2001
+From: Florian Weimer <fweimer@redhat.com>
+Date: Sun, 23 Apr 2023 18:30:33 +0200
+Subject: [PATCH] Add additional #include directives for C99 compatibility
+
+https://github.com/Mellanox/mstflint/pull/774
+Avoid implicit declarations of cibfw_register_mfai_pack,
+cibfw_register_mfai_unpack, cibfw_register_mfai_size by including
+<tools_layouts/cibfw_layouts.h>, and of getenv by including
+<stdlib.h>.
+---
+ mflash/mflash_gw.c | 2 ++
+ mflash/mflash_new_gw.c | 3 +++
+ reg_access/reg_access.c | 1 +
+ 3 files changed, 6 insertions(+)
+
+diff --git a/mflash/mflash_gw.c b/mflash/mflash_gw.c
+index f296700d..55e5cb9d 100644
+--- a/mflash/mflash_gw.c
++++ b/mflash/mflash_gw.c
+@@ -43,6 +43,8 @@
+ #include "mflash_access_layer.h"
+ #include "flash_int_defs.h"
+
++#include <stdlib.h>
++
+ #ifdef __WIN__
+ //
+ // Windows (Under DDK)
+diff --git a/mflash/mflash_new_gw.c b/mflash/mflash_new_gw.c
+index 3bd044ea..4d0bb21d 100644
+--- a/mflash/mflash_new_gw.c
++++ b/mflash/mflash_new_gw.c
+@@ -42,6 +42,9 @@
+ #include "mflash_dev_capability.h"
+ #include "mflash_access_layer.h"
+ #include "flash_int_defs.h"
++
++#include <stdlib.h>
++
+ #define DPRINTF(args) \
+ do \
+ { \
+diff --git a/reg_access/reg_access.c b/reg_access/reg_access.c
+index 622b1a15..736e67b3 100644
+--- a/reg_access/reg_access.c
++++ b/reg_access/reg_access.c
+@@ -37,6 +37,7 @@
+ #include <tools_layouts/reg_access_hca_layouts.h>
+ #include <tools_layouts/reg_access_switch_layouts.h>
+ #include <tools_layouts/tools_open_layouts.h>
++#include <tools_layouts/cibfw_layouts.h>
+
+ #define REG_ID_PCNR 0x5050
+ #define REG_ID_PAOS 0x5006
diff --git a/sys-fabric/mstflint/mstflint-4.23.0_p1.ebuild b/sys-fabric/mstflint/mstflint-4.23.0_p1.ebuild
new file mode 100644
index 000000000000..44fd3ec31adb
--- /dev/null
+++ b/sys-fabric/mstflint/mstflint-4.23.0_p1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="Mstflint - an open source version of MFT (Mellanox Firmware Tools)"
+HOMEPAGE="https://github.com/Mellanox/mstflint"
+LICENSE="|| ( GPL-2 BSD-2 )"
+KEYWORDS="~amd64 ~x86"
+EGIT_COMMIT="acfaf553f2f571b1f9256b6cd558eafa767d9172"
+MY_PV=${PV/_p/-}
+MY_P=""
+SRC_URI="https://github.com/Mellanox/mstflint/archive/v${MY_PV}.tar.gz -> ${P}.tar.gz"
+IUSE="adb-generic-tools inband ssl"
+SLOT="0"
+RDEPEND="dev-db/sqlite:3=
+ sys-libs/zlib:=
+ inband? ( sys-cluster/rdma-core )
+ adb-generic-tools? (
+ dev-libs/boost:=
+ dev-libs/expat:=
+ )
+ ssl? ( dev-libs/openssl:= )"
+DEPEND="${RDEPEND}"
+S="${WORKDIR}/${PN}-${MY_PV}"
+PATCHES=("${FILESDIR}"/mstflint-4.23.0_p1-C99-compat.patch)
+
+src_prepare() {
+ default
+ sed -e 's: \*.o: .libs/*.o:' -e 's: tools_dev_types.o: .libs/tools_dev_types.o:' \
+ -i cmdif/Makefile.am dev_mgt/Makefile.am reg_access/Makefile.am || die
+ echo '#define TOOLS_GIT_SHA "'${EGIT_COMMIT}'"' > ./common/gitversion.h || die
+}
+
+src_configure() {
+ eautoreconf
+ econf $(use_enable inband) $(use_enable ssl openssl) $(use adb-generic-tools && printf -- '--enable-adb-generic-tools')
+}
+
+src_compile() {
+ if use adb-generic-tools; then
+ pushd ext_libs/json >/dev/null || die
+ emake
+ popd >/dev/null || die
+ fi
+ default
+}