summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-07-30 13:16:33 +0200
committerMichał Górny <mgorny@gentoo.org>2021-07-30 20:13:47 +0200
commit6fdb52551639588e1b06ea69d902c5ccfd25632f (patch)
tree0beaf42bd3302fa6ccadc0f8ba6f52c8b73f7e33 /sys-devel
parentdev-ml/llvm-ocaml: Bump live to 14* (diff)
downloadgentoo-6fdb52551639588e1b06ea69d902c5ccfd25632f.tar.gz
gentoo-6fdb52551639588e1b06ea69d902c5ccfd25632f.tar.bz2
gentoo-6fdb52551639588e1b06ea69d902c5ccfd25632f.zip
sys-devel/clang-common: Bump live to 14*
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/clang-common/clang-common-14.0.0.9999.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/sys-devel/clang-common/clang-common-14.0.0.9999.ebuild b/sys-devel/clang-common/clang-common-14.0.0.9999.ebuild
new file mode 100644
index 000000000000..03e4441b91b9
--- /dev/null
+++ b/sys-devel/clang-common/clang-common-14.0.0.9999.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit bash-completion-r1 llvm.org
+
+DESCRIPTION="Common files shared between multiple slots of clang"
+HOMEPAGE="https://llvm.org/"
+
+LICENSE="Apache-2.0-with-LLVM-exceptions UoI-NCSA"
+SLOT="0"
+KEYWORDS=""
+IUSE=""
+
+PDEPEND="sys-devel/clang:*"
+
+LLVM_COMPONENTS=( clang/utils/bash-autocomplete.sh )
+llvm.org_set_globals
+S=${WORKDIR}/clang/utils
+
+src_install() {
+ newbashcomp bash-autocomplete.sh clang
+}