summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-05-11 04:11:56 +0000
committerSam James <sam@gentoo.org>2022-05-11 04:12:03 +0000
commitd56bcca2755f84993d98c4bd703e6db5da654917 (patch)
treebe6da684d00f85d65a1b76421f6691eee81e7fe5 /sys-devel/gnuconfig
parentnet-p2p/arti: add 0.3.0 (diff)
downloadgentoo-d56bcca2755f84993d98c4bd703e6db5da654917.tar.gz
gentoo-d56bcca2755f84993d98c4bd703e6db5da654917.tar.bz2
gentoo-d56bcca2755f84993d98c4bd703e6db5da654917.zip
sys-devel/gnuconfig: sync live
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-devel/gnuconfig')
-rw-r--r--sys-devel/gnuconfig/gnuconfig-20220508.ebuild14
-rw-r--r--sys-devel/gnuconfig/gnuconfig-99999999.ebuild16
2 files changed, 13 insertions, 17 deletions
diff --git a/sys-devel/gnuconfig/gnuconfig-20220508.ebuild b/sys-devel/gnuconfig/gnuconfig-20220508.ebuild
index fcdf54a96129..3c5c54ade825 100644
--- a/sys-devel/gnuconfig/gnuconfig-20220508.ebuild
+++ b/sys-devel/gnuconfig/gnuconfig-20220508.ebuild
@@ -3,12 +3,12 @@
EAPI="7"
-if [[ ${PV} == "99999999" ]] ; then
+if [[ ${PV} == 99999999 ]] ; then
EGIT_REPO_URI="https://git.savannah.gnu.org/r/config.git"
inherit git-r3
else
- SRC_URI="https://dev.gentoo.org/~polynomial-c/dist/${PN}/${P}.tar.xz"
+ SRC_URI="https://dev.gentoo.org/~sam/distfiles/${CATEGORY}/${PN}/${P}.tar.xz"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris ~x86-winnt"
S="${WORKDIR}"
fi
@@ -18,12 +18,11 @@ HOMEPAGE="https://savannah.gnu.org/projects/config"
LICENSE="GPL-3+-with-autoconf-exception"
SLOT="0"
-IUSE=""
maint_pkg_create() {
- cd "${S}"
+ cd "${S}" || die
- make ChangeLog || die
+ emake ChangeLog
local ver=$(gawk '{ gsub(/-/, "", $1); print $1; exit }' ChangeLog)
[[ ${#ver} != 8 ]] && die "invalid version '${ver}'"
@@ -36,7 +35,7 @@ maint_pkg_create() {
}
src_unpack() {
- if [[ ${PV} == "99999999" ]] ; then
+ if [[ ${PV} == 99999999 ]] ; then
git-r3_src_unpack
maint_pkg_create
else
@@ -46,11 +45,10 @@ src_unpack() {
src_prepare() {
default
+
eapply "${S}"/*.patch
}
-src_compile() { :;}
-
src_test() {
emake check
}
diff --git a/sys-devel/gnuconfig/gnuconfig-99999999.ebuild b/sys-devel/gnuconfig/gnuconfig-99999999.ebuild
index e4c1ec17f5df..3c5c54ade825 100644
--- a/sys-devel/gnuconfig/gnuconfig-99999999.ebuild
+++ b/sys-devel/gnuconfig/gnuconfig-99999999.ebuild
@@ -3,13 +3,13 @@
EAPI="7"
-if [[ ${PV} == "99999999" ]] ; then
+if [[ ${PV} == 99999999 ]] ; then
EGIT_REPO_URI="https://git.savannah.gnu.org/r/config.git"
inherit git-r3
else
- SRC_URI="https://dev.gentoo.org/~whissi/dist/${PN}/${P}.tar.xz"
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris ~x86-winnt"
+ SRC_URI="https://dev.gentoo.org/~sam/distfiles/${CATEGORY}/${PN}/${P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris ~x86-winnt"
S="${WORKDIR}"
fi
@@ -18,12 +18,11 @@ HOMEPAGE="https://savannah.gnu.org/projects/config"
LICENSE="GPL-3+-with-autoconf-exception"
SLOT="0"
-IUSE=""
maint_pkg_create() {
- cd "${S}"
+ cd "${S}" || die
- make ChangeLog || die
+ emake ChangeLog
local ver=$(gawk '{ gsub(/-/, "", $1); print $1; exit }' ChangeLog)
[[ ${#ver} != 8 ]] && die "invalid version '${ver}'"
@@ -36,7 +35,7 @@ maint_pkg_create() {
}
src_unpack() {
- if [[ ${PV} == "99999999" ]] ; then
+ if [[ ${PV} == 99999999 ]] ; then
git-r3_src_unpack
maint_pkg_create
else
@@ -46,11 +45,10 @@ src_unpack() {
src_prepare() {
default
+
eapply "${S}"/*.patch
}
-src_compile() { :;}
-
src_test() {
emake check
}