summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexys Jacob <ultrabug@gentoo.org>2019-12-12 23:22:44 +0100
committerAlexys Jacob <ultrabug@gentoo.org>2019-12-12 23:23:57 +0100
commitdae775967e700cfc6ff5700b6a2f3a205236cf4c (patch)
treeef0ae79b51a93f7b50aafeca1880fa65dcbeca4a /sys-cluster/crmsh/crmsh-4.1.0.ebuild
parentx11-misc/py3status: version bump (diff)
downloadgentoo-dae775967e700cfc6ff5700b6a2f3a205236cf4c.tar.gz
gentoo-dae775967e700cfc6ff5700b6a2f3a205236cf4c.tar.bz2
gentoo-dae775967e700cfc6ff5700b6a2f3a205236cf4c.zip
sys-cluster/crmsh: version bump, fix #669568
Package-Manager: Portage-2.3.80, Repoman-2.3.19 Signed-off-by: Alexys Jacob <ultrabug@gentoo.org>
Diffstat (limited to 'sys-cluster/crmsh/crmsh-4.1.0.ebuild')
-rw-r--r--sys-cluster/crmsh/crmsh-4.1.0.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/sys-cluster/crmsh/crmsh-4.1.0.ebuild b/sys-cluster/crmsh/crmsh-4.1.0.ebuild
new file mode 100644
index 000000000000..493af7ad63b2
--- /dev/null
+++ b/sys-cluster/crmsh/crmsh-4.1.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_{5,6,7} )
+
+AUTOTOOLS_AUTORECONF=true
+KEYWORDS=""
+SRC_URI=""
+
+if [[ ${PV} == *9999 ]]; then
+ EGIT_REPO_URI="https://github.com/crmsh/crmsh"
+ inherit git-2
+ S="${WORKDIR}/${PN}-${MY_TREE}"
+else
+ SRC_URI="https://github.com/crmsh/crmsh/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~hppa ~x86"
+fi
+
+inherit eutils python-r1
+
+DESCRIPTION="Pacemaker command line interface for management and configuration"
+HOMEPAGE="https://crmsh.github.io/"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="${PYTHON_DEPS}
+ >=sys-cluster/pacemaker-1.1.9"
+RDEPEND="${DEPEND}
+ dev-python/lxml[${PYTHON_USEDEP}]"
+
+src_configure() {
+ ./autogen.sh || die
+ econf
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ python_foreach_impl python_optimize
+}