summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Jolly <kangie@gentoo.org>2024-06-30 00:58:52 +1000
committerMatt Jolly <kangie@gentoo.org>2024-06-30 01:00:05 +1000
commitc53f1bfb1a2aa2512cc2bf01eb93553efc8bbc01 (patch)
tree71f50cd8d22a98d964401609848256cb54844de1 /sys-boot
parentdev-python/markdown2: destabilize 2.4.13 for ~ppc (diff)
downloadgentoo-c53f1bfb1a2aa2512cc2bf01eb93553efc8bbc01.tar.gz
gentoo-c53f1bfb1a2aa2512cc2bf01eb93553efc8bbc01.tar.bz2
gentoo-c53f1bfb1a2aa2512cc2bf01eb93553efc8bbc01.zip
sys-boot/plymouth-openrc-plugin: add 0.2.0
Signed-off-by: Matt Jolly <kangie@gentoo.org>
Diffstat (limited to 'sys-boot')
-rw-r--r--sys-boot/plymouth-openrc-plugin/Manifest1
-rw-r--r--sys-boot/plymouth-openrc-plugin/plymouth-openrc-plugin-0.2.0.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/sys-boot/plymouth-openrc-plugin/Manifest b/sys-boot/plymouth-openrc-plugin/Manifest
index f2ecc2ad5424..8cef1c5ec038 100644
--- a/sys-boot/plymouth-openrc-plugin/Manifest
+++ b/sys-boot/plymouth-openrc-plugin/Manifest
@@ -1 +1,2 @@
DIST plymouth-openrc-plugin-0.1.3.tar.gz 9404 BLAKE2B 809cfab881ef47565badfc330b77ae07a8bbbddf822cbdb50f2d1d2a0c95f915ac5024e02400ab2ea9d8f98dc466a8a3cbad92805587f77a00e58c9f9d78d388 SHA512 b07a4d9d56c8f49d5b0a91799fe0100eac705cd2a266674539948fdc661876474a93d8ed5f329f097a1fc5dc571f3b3c00322191fb77d2a7e32b1ff192ca0a6b
+DIST plymouth-openrc-plugin-0.2.0.tar.gz 10325 BLAKE2B ee66b158d366f5bf12504d1546ec00906f9e73760308975dbc4ea26e5622ee10ab877b47a13269ae11576c7d3e8b4c9484ca0dc61efce0f78f38344515ce4c5e SHA512 4156b291c49cf5c55c78071439530a35f5ec03b1e022bb022839e1b89567653ebb70bf3471b82ae0ecec8fc84c3f41ee2cc6b3de1fa52811a96d0812a6ada772
diff --git a/sys-boot/plymouth-openrc-plugin/plymouth-openrc-plugin-0.2.0.ebuild b/sys-boot/plymouth-openrc-plugin/plymouth-openrc-plugin-0.2.0.ebuild
new file mode 100644
index 000000000000..6d409e02a6d6
--- /dev/null
+++ b/sys-boot/plymouth-openrc-plugin/plymouth-openrc-plugin-0.2.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson
+
+DESCRIPTION="Plymouth plugin for OpenRC"
+HOMEPAGE="https://github.com/Kangie/plymouth-openrc-plugin"
+SRC_URI="https://github.com/Kangie/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="debug"
+
+DEPEND="sys-apps/openrc"
+RDEPEND="${DEPEND}
+ sys-boot/plymouth
+ !sys-apps/systemd"
+
+src_configure() {
+ local emesonargs=(
+ -Ddebug=$(usex debug true false)
+ )
+ meson_src_configure
+}
+
+pkg_postinst() {
+ if [[ -z ${REPLACING_VERSIONS} ]]; then
+ ewarn "The 'rc_interactive' feature in /etc/rc.conf must be disabled"
+ ewarn "for Plymouth work properly with OpenRC init system."
+ fi
+}