summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2023-07-11 20:12:01 +0200
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2023-07-20 13:32:17 +0200
commitb42e1af6cee762ebc65bcb3ef478615afa4cb0da (patch)
tree8c66a9624847dd2cace6347324ef6e163cb4e276 /sys-boot
parentsys-apps/systemd-utils: use secureboot.eclass to sign efi files (diff)
downloadgentoo-b42e1af6cee762ebc65bcb3ef478615afa4cb0da.tar.gz
gentoo-b42e1af6cee762ebc65bcb3ef478615afa4cb0da.tar.bz2
gentoo-b42e1af6cee762ebc65bcb3ef478615afa4cb0da.zip
sys-boot/refind: use secureboot.eclass to sign efi files
Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'sys-boot')
-rw-r--r--sys-boot/refind/refind-0.13.3.1.ebuild7
1 files changed, 5 insertions, 2 deletions
diff --git a/sys-boot/refind/refind-0.13.3.1.ebuild b/sys-boot/refind/refind-0.13.3.1.ebuild
index 73f27787890e..327f17b7022b 100644
--- a/sys-boot/refind/refind-0.13.3.1.ebuild
+++ b/sys-boot/refind/refind-0.13.3.1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-inherit toolchain-funcs
+inherit toolchain-funcs secureboot
DESCRIPTION="The UEFI Boot Manager by Rod Smith"
HOMEPAGE="https://www.rodsbooks.com/refind/"
@@ -39,6 +39,7 @@ pkg_setup() {
export EFIARCH=x64
export BUILDARCH=x86_64
fi
+ secureboot_pkg_setup
}
src_prepare() {
@@ -111,6 +112,8 @@ src_install() {
dosbin "mkrlconf"
dosbin "mvrefind"
dosbin "refind-mkdefault"
+
+ secureboot_auto_sign --in-place
}
pkg_postinst() {