summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2024-01-31 09:51:16 +0100
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2024-02-02 07:16:13 +0100
commit867aa4eed03b8f56fc62c3686654abf943106309 (patch)
tree7a4746ba4c4163daa1c4676a9bc8edcfae834c80 /sys-boot
parentsys-apps/kexec-tools: add installkernel as optfeature (diff)
downloadgentoo-867aa4eed03b8f56fc62c3686654abf943106309.tar.gz
gentoo-867aa4eed03b8f56fc62c3686654abf943106309.tar.bz2
gentoo-867aa4eed03b8f56fc62c3686654abf943106309.zip
sys-boot/lilo: add installkernel as optfeature
package installs /etc/kernel/postinst.d/zz-runlilo which will be executed by traditional installkernel (i.e. if the systemd-kernel-install flag is disabled). Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'sys-boot')
-rw-r--r--sys-boot/lilo/lilo-24.2-r1.ebuild7
1 files changed, 5 insertions, 2 deletions
diff --git a/sys-boot/lilo/lilo-24.2-r1.ebuild b/sys-boot/lilo/lilo-24.2-r1.ebuild
index 66040236a6d6..a1e7a24913fd 100644
--- a/sys-boot/lilo/lilo-24.2-r1.ebuild
+++ b/sys-boot/lilo/lilo-24.2-r1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="7"
-inherit flag-o-matic toolchain-funcs
+inherit flag-o-matic optfeature toolchain-funcs
DOLILO_V="0.6"
IUSE="static minimal pxeserial device-mapper"
@@ -184,4 +184,7 @@ pkg_postinst() {
einfo "edit /etc/conf.d/dolilo to harness its full potential."
echo
fi
+
+ optfeature "automatically updating lilo's configuration on each kernel installation" \
+ "sys-kernel/installkernel[-systemd]"
}