summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiogo Pereira <sir.suriv@gmail.com>2017-01-07 02:41:22 +0000
committerMatthew Thode <prometheanfire@gentoo.org>2017-01-12 11:34:04 -0600
commit8c76a6b7fda1d0b8703823edd3d17a9c63cd6c17 (patch)
tree4ebb8ca5051f9f6e29418a3291f992986f47d6d2 /sys-block/targetcli-fb/targetcli-fb-2.1.45.ebuild
parentdev-python/rtslib-fb: version bump to 2.1.62 (diff)
downloadgentoo-8c76a6b7fda1d0b8703823edd3d17a9c63cd6c17.tar.gz
gentoo-8c76a6b7fda1d0b8703823edd3d17a9c63cd6c17.tar.bz2
gentoo-8c76a6b7fda1d0b8703823edd3d17a9c63cd6c17.zip
sys-block/targetcli-fb: version bump to 2.1.45
Package-Manager: portage-2.3.0 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'sys-block/targetcli-fb/targetcli-fb-2.1.45.ebuild')
-rw-r--r--sys-block/targetcli-fb/targetcli-fb-2.1.45.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/sys-block/targetcli-fb/targetcli-fb-2.1.45.ebuild b/sys-block/targetcli-fb/targetcli-fb-2.1.45.ebuild
new file mode 100644
index 000000000000..f052dca4dd78
--- /dev/null
+++ b/sys-block/targetcli-fb/targetcli-fb-2.1.45.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
+inherit distutils-r1 versionator
+
+MY_PV=$(replace_version_separator 2 '.fb' ${PV})
+
+DESCRIPTION="Command shell for managing Linux LIO kernel target"
+HOMEPAGE="https://github.com/open-iscsi/targetcli-fb"
+SRC_URI="https://github.com/open-iscsi/${PN}/archive/v${MY_PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="dev-python/configshell-fb[${PYTHON_USEDEP}]
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ >=dev-python/rtslib-fb-2.1.62[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ !sys-block/targetcli"
+
+S=${WORKDIR}/${PN}-${MY_PV}
+
+src_install() {
+ distutils-r1_src_install
+
+ keepdir /etc/target /etc/target/backup
+ doman targetcli.8
+}